Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#1374 closed enhancement (fixed)

launching applications from Terminal produces unexpected window size

Reported by: walter Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: 0.85.x
Severity: Unspecified Keywords:
Cc: Distribution/OS: Ubuntu
Bug Status: Unconfirmed

Description

The behavior when launching an application from the Terminal, e.g., inkscape, is much different with metacity/0.86. The window created is no longer full screen and doesn't feel nearly as Sugary as it used to under 0.84. Not sure if this was the intention and perhaps programs like the gimp are easier to use now, so this is perhaps more of a comment than a bug report. Should we recommend some command line options for launching programs to have them go to full screen?

(tested under sugar-jhbuild run sugar-emulator --fullscreen on Ubuntu)

Change History (2)

comment:1 Changed 12 years ago by walter

  • Milestone changed from Unspecified by Release Team to 0.88
  • Resolution set to fixed
  • Status changed from new to closed
  • Type changed from defect to enhancement

<tomeu> walterbender: yes, this is intended because the alternative is to maintain a blacklist of window names that shouldn't be maximized
<tomeu> walterbender: the upside is that ubuntu netbook remix is already maintaining such list, so we could just copy it periodically
<tomeu> walterbender: if we maximize all windows, multi-window apps will break
<walterbender> tomeu: so is there a simple way to tell an application to launch full screen we can recommend?
<tomeu> walterbender: some have command line switches
<tomeu> walterbender: and alternative is using libsugarize, that will make it behave more like a proper activity
<walterbender> tomeu: so it is application by application... so be it.
<tomeu> walterbender: maybe a launcher script could be cooked that sets the appropriate window properties
<walterbender> tomeu: I've not tried it in a while, but maybe I'll add that to my test chores this week
<tomeu> walterbender: bertf may know already about something like that
<walterbender> and add it to the release notes

<walterbender> tomeu: I'll add this exchange to the ticket and close it.

<tomeu> walterbender: you can add a feature request if you wish, it should be actually quite trivial to implement
<tomeu> it just have the downsides of a fixed blacklist
<walterbender> tomeu: something to discuss for 0.88 but not for 0.86 :)

comment:2 Changed 8 years ago by dnarvaez

  • Milestone 0.88 deleted

Milestone 0.88 deleted

Note: See TracTickets for help on using tickets.