Opened 12 years ago

Closed 8 years ago

#1352 closed defect (wontfix)

Prevent creating parent-less dialogs

Reported by: alsroot Owned by: erikos
Priority: High Milestone: Unspecified
Component: Sugar Version: 0.85.x
Severity: Major Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

After moving to metacity we have many issues due to the fact that activity authors do not pass parent while creating ObjectChooser object(for example).

It could be useful for ObjectChooser to make parent argument required(it could be None) for 0.88 and add deprecation warning for 0.86 or do some smart job to autoset parent on shell side.

Also parent argument could be required for sugar.graphics.Window(w/ warning in 0.86) or new Dialog class.

Change History (7)

comment:1 Changed 12 years ago by alsroot

  • Type changed from enhancement to defect

Shanged type to defect since parent-less dialogs are bugs for 0.86.

comment:2 Changed 12 years ago by alsroot

  • Milestone changed from 0.86 to 0.88

Milestone to 0.88, since we are in code freeze

comment:3 Changed 11 years ago by tomeu

  • Bug Status changed from Unconfirmed to Assigned
  • Component changed from sugar to sugar-toolkit
  • Milestone changed from 0.88 to 0.90
  • Owner changed from tomeu to erikos
  • Severity changed from Unspecified to Major

I agree on this, but would be an API change so needs to be done at the start of a release cycle so activities have time to adapt. do people agree?

comment:4 Changed 8 years ago by dnarvaez

  • Component changed from sugar-toolkit to Sugar

comment:5 Changed 8 years ago by dnarvaez

  • Milestone changed from 0.90 to Unspecified

comment:6 Changed 8 years ago by dnarvaez

  • Bug Status changed from Assigned to Unconfirmed

comment:7 Changed 8 years ago by dnarvaez

  • Resolution set to wontfix
  • Status changed from new to closed

I tend to think this not worth anymore, it has been there for 4 years, it's not critical and the future toolkit is probably going to be html based.

Note: See TracTickets for help on using tickets.