Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#1351 closed defect (obsolete)

Fails while removing active Journal objects

Reported by: alsroot Owned by: alsroot
Priority: High Milestone:
Component: Sugar Version: 0.85.x
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

|TestCase|

  • resume any non-last Journal entry
  • Erase this entry from Journal
  • Erase next etnry
  • sugar fails with traceback:
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/jarabe/journal/palettes.py", line 142, in __erase_activate_cb
    model.delete(self._metadata['uid'])
  File "/usr/lib64/python2.6/site-packages/jarabe/journal/model.py", line 452, in delete
    _get_datastore().delete(object_id)
  File "/usr/lib64/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib64/python2.6/site-packages/dbus/connection.py", line 622, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.OSError: Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib64/python2.6/site-packages/carquinyol/datastore.py", line 299, in delete
    os.removedirs(entry_path)
  File "/usr/lib64/python2.6/os.py", line 170, in removedirs
    rmdir(name)
OSError: [Errno 39] Directory not empty: '/home/me/.sugar/default/datastore/1e/1edf89d0-a73e-4694-9227-7b158bfc1627'

Change History (3)

comment:1 Changed 12 years ago by alsroot

  • Owner changed from tomeu to alsroot
  • Status changed from new to assigned

comment:2 Changed 12 years ago by alsroot

  • Resolution set to obsolete
  • Status changed from assigned to closed

looks like it was consequence of #1359

comment:3 Changed 8 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.