Opened 12 years ago

Closed 10 years ago

#1347 closed defect (fixed)

help acitivity doesn't load

Reported by: dgd Owned by: garycmartin
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: ActivityTeam Version: Git as of bugdate
Severity: Critical Keywords:
Cc: Distribution/OS: Ubuntu
Bug Status: Unconfirmed

Description

video: coming soon
log:
DEBUG:xpcom:Python Factory creating ModuleLoader
1252949907.405797 DEBUG xpcom: Python Factory creating ModuleLoader
Registering '@…/module-loader/python;1' (libpyloader.so)
Registering '@…/network/protocol/about;1?what=python' (pyabout.py)
returning /home/user/.sugar/default/org.laptop.HelpActivity/data/gecko/prefs.js for key NS_APP_PREFS_50_FILE
1252949907.596426 DEBUG root: * Act e9ca77fe21fac72a9a0008f1db75c9426057a3e1, mesh instance None, scope private
1252949907.598492 DEBUG root: Creating a jobject.
1252949907.602803 DEBUG root: datastore.write
1252949907.609532 DEBUG root: dbus_helpers.create: 53957bc1-b45c-4f38-9f3f-bbcecc71174a
1252949907.619275 DEBUG root: Written object 53957bc1-b45c-4f38-9f3f-bbcecc71174a to the datastore.
1252949907.670593 DEBUG root: PaletteWindow.popdown immediate True
1252949907.697972 DEBUG root: PaletteWindow.popdown immediate True
1252949907.721487 WARNING root: No gtk.AccelGroup in the top level window.
1252949907.725398 WARNING root: No gtk.AccelGroup in the top level window.
/home/user/sugar-jhbuild/install/lib/python2.6/site-packages/sugar/graphics/window.py:276: DeprecationWarning: use toolbar_box instead of toolbox

warnings.warn('use toolbar_box instead of toolbox', DeprecationWarning)

/usr/lib/xulrunner-1.9.0.14/python/xpcom/init__.py:54: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6

self.message = message

Traceback (most recent call last):

File "/home/user/sugar-jhbuild/install/bin/sugar-activity", line 21, in <module>

main.main()

File "/home/user/sugar-jhbuild/install/lib/python2.6/site-packages/sugar/activity/main.py", line 146, in main

create_activity_instance(activity_constructor, activity_handle)

File "/home/user/sugar-jhbuild/install/lib/python2.6/site-packages/sugar/activity/main.py", line 35, in create_activity_instance

activity = constructor(handle)

File "/home/user/Activities/Help.activity/helpactivity.py", line 50, in init

toolbar = Toolbar(self._web_view)

File "/home/user/Activities/Help.activity/helpactivity.py", line 93, in init

self._web_view.web_progress.addProgressListener(self._listener, mask)

File "/home/user/sugar-jhbuild/install/lib/python2.6/site-packages/hulahop/webview.py", line 280, in get_web_progress

return self.doc_shell.queryInterface(interfaces.nsIWebProgress)

File "/home/user/sugar-jhbuild/install/lib/python2.6/site-packages/hulahop/webview.py", line 277, in get_doc_shell

return requestor.getInterface(interfaces.nsIDocShell)

File "<XPCOMObject method 'getInterface'>", line 3, in getInterface

xpcom.Exception/usr/lib/xulrunner-1.9.0.14/python/xpcom/init__.py:62: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6

message = self.message

: -2147467262 (-2147467262)
1252949907.768030 DEBUG root: _cleanup_temp_files
Activity died: pid 19574 condition 256 data (None, <open file '<fdopen>', mode 'w' at 0x9cd3250>)

Change History (3)

comment:1 Changed 12 years ago by garycmartin

Hmmm, looks like you're trying to run the old version of help. There is an updated version (in french) that runs fine:

http://git.sugarlabs.org/projects/helpfr

But the content is for the old 0.82 Sugar as shipped by OLPC, so not much use for 0.86. There would need to be a major floss manuals sprint to pull together new help content for 0.86. And the 0.86 (beta) release was only really available to non-developers as of the weekend so I'm not sure how document type folks would be able to document unreleased software... The 0.86 release notes are not even finalised yet!.

comment:2 Changed 12 years ago by alsroot

  • Component changed from sugar to ActivityTeam
  • Owner changed from tomeu to garycmartin

comment:3 Changed 10 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from new to closed

I'm going to close this beacuase help v12 is loading on the xo, re-open if the subject of the bug still applies.

Note: See TracTickets for help on using tickets.