Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#1339 closed defect (duplicate)

After download, 'Show in Journal' option doesnt switch you to the Journal

Reported by: HoboPrimate Owned by: alsroot
Priority: Immediate Milestone:
Component: journal Version: 0.85.x
Severity: Blocker Keywords: r+
Cc: Distribution/OS: Unspecified
Bug Status: Assigned

Description

1 - Download some file in Browse.
2 - When it completes, click on 'Show in Journal' option. You aren't sent to the journal.
3 - Switch to the Journal, the downloaded entry is shown in its detailed view.

Attachments (1)

sugar-1339.patch (1.1 KB) - added by alsroot 12 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 12 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned
  • Milestone changed from Unspecified by Release Team to 0.86
  • Priority changed from Unspecified by Maintainer to Immediate
  • Version changed from Git as of bugdate to 0.85.x

A regression.

comment:2 Changed 12 years ago by erikos

  • Distribution/OS changed from Ubuntu to Unspecified
  • Severity changed from Unspecified to Blocker

I added an alert to the helloworld activity and opened an existing journal entry with the show_object_in_journal call fine.

comment:3 Changed 12 years ago by erikos

some more data:

  • I can still open the object fine with the alert, when adding a hulahop canvas in helloworld
  • adding the alert I use in helloworld to browse works too
  • when I download a file in Browse and do not hit the show_me option in the alert, and start another activity (only window switching does not work), and then go back to Browse and use the show_me option it does work fine

comment:4 Changed 12 years ago by alsroot

  • Keywords r? added

Looks like metacity doesn't raise windows from non-icon state.

|TestCase|

  • start sugar
  • do not open Journal
  • start Browse from Home view
  • download files
  • click "Show in Journal"
  • sugar switches to journal ok(Journal's window state is iconified)

|TestCase|

  • follow previous test case
  • return to Browse
  • download and click "Show in Journal"
  • sugar doesn't switch to Journal

Changed 12 years ago by alsroot

comment:5 Changed 12 years ago by alsroot

  • Component changed from Browse to journal
  • Owner changed from erikos to tomeu
  • Status changed from new to assigned

comment:6 Changed 12 years ago by erikos

Works fine for me.

comment:7 Changed 12 years ago by tomeu

  • Keywords r+ added; r? removed
  • Owner changed from tomeu to alsroot

comment:8 Changed 12 years ago by alsroot

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:9 Changed 12 years ago by alsroot

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:10 Changed 12 years ago by alsroot

  • Resolution set to duplicate
  • Status changed from reopened to closed

dup of #1423

comment:11 Changed 8 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.