Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#1325 closed defect (notabug)

Keyboard control panel component fails on opening

Reported by: alsroot Owned by: alsroot
Priority: Urgent Milestone:
Component: Sugar Version: 0.85.x
Severity: Unspecified Keywords:
Cc: sascha_silbe Distribution/OS: Ubuntu
Bug Status: Unconfirmed

Description

PPA: https://launchpad.net/~alsroot/+archive/sugar-0.86

|TestCase|

  • new .sugar environment
  • clock on Keyboard component
  • it fails with traceback
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/jarabe/controlpanel/gui.py", line 320, in __select_option_cb
    self.show_section_view(option)
  File "/usr/lib/pymodules/python2.6/jarabe/controlpanel/gui.py", line 218, in show_section_view
    self._options[option]['alerts'])
  File "/usr/share/sugar/extensions/cpsection/keyboard/view.py", line 175, in __init__
    self._setup_kmodel()
  File "/usr/share/sugar/extensions/cpsection/keyboard/view.py", line 208, in _setup_kmodel
    if self._kmodel in row[0]:
TypeError: 'in <string>' requires string as left operand, not NoneType

Attachments (1)

sugar-jhbuild-cp-screenshot.png (65.4 KB) - added by garycmartin 12 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 12 years ago by tomeu

  • Owner changed from tomeu to sayamindu
  • Status changed from new to assigned

comment:2 Changed 12 years ago by alsroot

  • Milestone changed from Unspecified by Release Team to 0.86
  • Owner changed from sayamindu to alsroot

Can't reproduce it in gentoo, looks like its a ubuntu specific,
need to investigate it closely

comment:3 Changed 12 years ago by alsroot

  • Priority changed from Unspecified by Maintainer to High

comment:4 Changed 12 years ago by tomeu

  • Priority changed from High to Urgent

comment:5 Changed 12 years ago by alsroot

  • Resolution set to notabug
  • Status changed from assigned to closed

hmm.. can't reproduce this fault any more
even in reinstalled environment

Changed 12 years ago by garycmartin

comment:6 follow-up: Changed 12 years ago by garycmartin

I was really hopeful to help test this (been trying a week or so), but I have NEVER seen it show up in the CP in sugar-jhbuild. Just uploaded a screen shot. This is a fresh sugar-jhbuild (in a Mac F11 VM).

comment:7 in reply to: ↑ 6 ; follow-up: Changed 12 years ago by alsroot

Replying to garycmartin:

I was really hopeful to help test this (been trying a week or so), but I have NEVER seen it show up in the CP in sugar-jhbuild. Just uploaded a screen shot. This is a fresh sugar-jhbuild (in a Mac F11 VM).

screenshot tells that you have really outdated sugar repo,
keyboard code was landed Tue Aug 25 22:49:25
or you don't have python-xklavier intalled(f12 should have this package I guess, the sources are here http://download.sugarlabs.org/sources/external/python-xklavier/)

comment:8 in reply to: ↑ 7 Changed 12 years ago by garycmartin

Replying to alsroot:

Replying to garycmartin:

I was really hopeful to help test this (been trying a week or so), but I have NEVER seen it show up in the CP in sugar-jhbuild. Just uploaded a screen shot. This is a fresh sugar-jhbuild (in a Mac F11 VM).

screenshot tells that you have really outdated sugar repo,
keyboard code was landed Tue Aug 25 22:49:25
or you don't have python-xklavier intalled(f12 should have this package I guess, the sources are here http://download.sugarlabs.org/sources/external/python-xklavier/)

I've been updating and building sugar-jhbuild here on F11 every day, sometimes several times a day as I see patches land for test. So I guess this is python-xklavier? never heard of it before, shouldn't sugar-jhbuild depscheck show this as a missing dependancy??

comment:9 Changed 12 years ago by alsroot

  • Cc sascha_silbe added

good question..

comment:10 Changed 8 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.