Opened 10 years ago

Closed 8 years ago

Last modified 7 years ago

#1274 closed defect (fixed)

Can not erase bookmark

Reported by: erikos Owned by: humitos
Priority: Unspecified by Maintainer Milestone:
Component: Read Version: Git as of bugdate
Severity: Major Keywords: 12.1.0, patch
Cc: godiard, humitos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

When I click on the bookmark to erase it, the dialog to edit the bookmark is displayed again.

Attachments (1)

0001-Alert-the-user-when-he-removes-a-bookmark-SL-1274.patch (2.2 KB) - added by humitos 8 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 10 years ago by sayamindu

Hmm - you need to click on the bookmark icon om the toolbar (again) to delete it (note that it remains active when the bookmark is around). Clicking on the bookmark just allows you to edit the notes that you associated with the bookmark.

Does it make sense to add a delete option to the edit-dialog that pops up ?

comment:2 Changed 8 years ago by greenfeld

I've tried clicking on the bookmark itself and that doesn't seem to delete it.

Tested in OLPC 12.1.0 os8/Read-99.

comment:3 Changed 8 years ago by greenfeld

  • Cc godiard added

comment:4 Changed 8 years ago by godiard

The procedure (obviously not obvious) is click again in the star button in the toolbar.

Is harder to see now, because the toogle button is showed without the needed grey rounded square, but a almost black square background. This issue was already reported.

comment:5 Changed 8 years ago by godiard

  • Keywords 12.1.0 added

comment:6 follow-up: Changed 8 years ago by godiard

  • Owner changed from sayamindu to godiard
  • Status changed from new to assigned

comment:7 Changed 8 years ago by garycmartin

Adding a standard Sugar Alert strip when deleting a bookmark would also provide some user feedback and a warning about the loss of data when your book mark is removed (e.g. your bookmark notes are lost). Also a future enhancement could be to show an optional tray across the bottom of the Read canvas listing all the pages you have bookmarked, like we do in Browse (and similar to Record).

comment:8 in reply to: ↑ 6 Changed 8 years ago by godiard

Replying to godiard:

Also a future enhancement could be to show an optional tray across the bottom of the
Read canvas listing all the pages you have bookmarked, like we do in Browse (and
similar to Record).

Yes, will be better for consistency too.

comment:9 Changed 8 years ago by humitos

  • Cc humitos added

comment:10 Changed 8 years ago by humitos

  • Keywords patch added
  • Owner changed from godiard to humitos
  • Status changed from assigned to accepted

I've already uploaded a patch. I would like to know if the text strings are right. I used "Delete bookmark" as title and "All the information related with this bookmark will be lost" as message.

comment:11 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from accepted to closed

Thanks, pushed. Will be available in Read 100

comment:12 Changed 7 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.