Opened 8 years ago

Closed 4 years ago

Last modified 4 years ago

#1206 closed enhancement (fixed)

reorganise home menu

Reported by: dsd Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: 0.85.x
Severity: Major Keywords: r+ dextrose
Cc: ChristophD, quozl, bernie Distribution/OS: Unspecified
Bug Status: Assigned

Description (last modified by tomeu)

As discussed on the mailing list:

  1. Restart option should be removed - can't think of why this would be

useful for our userbase

  1. Shutdown should be moved to the top of the menu as it's the most

common option

Attachments (2)

0001-Remove-Restart-option-from-buddy-menu-change-order-t.patch (1.7 KB) - added by tomeu 8 years ago.
0001-revert-earlier-fix-to-1206-and-use-gconf.patch (1.8 KB) - added by quozl 7 years ago.
proposed for discussion, restore restart as a gconf mediated menu option ... not sure if everything needed is done, and this patch has not been tested by me.

Download all attachments as: .zip

Change History (31)

comment:1 Changed 8 years ago by ChristophD

  • Cc ChristophD added

comment:2 Changed 8 years ago by quozl

  • Cc quozl added

A patch posted to sugar-devel by me.

comment:3 Changed 8 years ago by tomeu

  • Description modified (diff)
  • Keywords r? added

comment:4 Changed 8 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned
  • Keywords r+ added; r? removed
  • Milestone changed from Unspecified by Release Team to 0.86
  • Severity changed from Unspecified to Major
  • Version changed from Unspecified to 0.85.x

Thanks for the patch - looks good to me.

comment:5 Changed 8 years ago by tomeu

  • Resolution set to fixed
  • Status changed from new to closed

Was pushed as 9837838cabbc1873ab4733aabca4150bebe842e6

comment:6 Changed 7 years ago by bernie

People in Paraguay complained, and demanded the Restart function to be added back to Sugar: PY#672.

comment:7 Changed 7 years ago by bernie

  • Resolution fixed deleted
  • Status changed from closed to reopened

People in Uruguay complained as well.

I've reviewed the discussion in the mailing-list: removing Restart was the result of theoretical thinking ("if our software were perfect, nobody would ever need to restart"), not really a request from a deployment.

Given that users seem to hate this change, I recommend reverting this UI change or at least making it configurable with a gconf key, like we did for Logout.

comment:8 follow-up: Changed 7 years ago by dsd

The request came from Nepal.

comment:9 Changed 7 years ago by quozl

Has Nepal deployed 0.88 yet to test? They may have new input if they test it.

Changed 7 years ago by quozl

proposed for discussion, restore restart as a gconf mediated menu option ... not sure if everything needed is done, and this patch has not been tested by me.

comment:10 Changed 7 years ago by dsd

It was deployed in Nepal as a patch to 0.82 while I was there. But yes, they may have new input, as that was a year ago.

comment:11 in reply to: ↑ 8 Changed 7 years ago by bernie

Replying to dsd:

The request came from Nepal.

Out of curiosity, who asked for this change and why?

Reading the mailing list discussion, it sounds like it was decided between you and Christoph: http://www.mail-archive.com/sugar-devel@lists.sugarlabs.org/msg07984.html

comment:12 Changed 7 years ago by bernie

  • Keywords r? dextrose added; r+ removed

Resetting r? flag for the last patch appended by Quozl. I'll test it in dextrose shortly.

comment:13 Changed 7 years ago by dsd

Yes, the idea came from myself and Christoph while we were working on the deployment in Nepal, stemming off another idea originating from the local team. It was warmly accepted by the team there and deployed.

comment:14 Changed 7 years ago by tomeu

  • Keywords r+ added; r? removed

r+ from me, though I want to make explicit the risk of confusing users with configurable UI changes, because documentation is going to not always match.

So if deployments want this, please push.

comment:15 Changed 7 years ago by erikos

  • Milestone changed from 0.86 to 0.90

Please make sure that the order of the items stays as before. As far as I understood the learners that were confused by the change, were also by the new ordering. We should stay consistent if possible. (The order should be consistent with the other XO menus, too).

And of course - please land this today, we have UI freeze.

comment:16 Changed 7 years ago by quozl

Ordering of items:

sugar 0.82sugar 0.84quozl's patch above
Control Panel, Restart, Shutdown, RegisterShutdown, My Settings, RegisterShutdown, Restart, My Settings, Register

Consensus not clear to me. If ordering of items was to stay as before (0.82), then the only effective change would be Control Panel becoming My Settings.

comment:17 follow-ups: Changed 7 years ago by erikos

James, as far as I have understood, the idea was as well to go back to the old ordering to not confuse people. Bernie might want to comment here.

comment:18 in reply to: ↑ 17 Changed 7 years ago by quozl

Replying to erikos:

James, as far as I have understood, the idea was as well to go back to the old ordering to not confuse people.

Yes, but which old ordering. Be specific. The 0.84 ordering is deployed, to users who have never seen the 0.82 ordering, so changing it again in 0.90 isn't going to help them. The users who have learned the 0.82 ordering seem to be those who are complaining about the 0.84 ordering. Perhaps you want a gconf setting for the ordering now?

comment:19 Changed 7 years ago by erikos

Ok, the fact that 0.84 has been widely deployed already I would vote for the ordering like James described it.

Shutdown, Restart, My Settings, Register

It does not fix the issue people had when going from 0.82 to 0.84. Bad for us. In an ideal world we would have probably identified that issue with testing first in an deployment. Changing UI and workflow once you have users is hard...

comment:20 follow-up: Changed 7 years ago by virtusanqa

  • Type changed from defect to enhancement

Why don't you guys add it as an optional feature, Then the people who needs the restart menu can Enable it and others can disable the restart option...?

comment:21 in reply to: ↑ 20 Changed 7 years ago by bernie

Replying to virtusanqa:

Why don't you guys add it as an optional feature, Then the people who needs the restart menu can Enable it and others can disable the restart option...?

+1

comment:22 in reply to: ↑ 17 ; follow-up: Changed 7 years ago by bernie

Replying to erikos:

James, as far as I have understood, the idea was as well to go back to the old ordering to not confuse people. Bernie might want to comment here.

I agree with erikos. Preferred ordering for me would be the same of 0.82, with the label "My Settings" and, perhaps, the Register button showing new schoolserver icon designed by Gary C. Martin.

comment:23 Changed 7 years ago by dsd

I'd like to see Shutdown kept as the top option, as it is the most frequently used, and this helps new computer users significantly. We did do field testing of this. see original discussion http://www.mail-archive.com/sugar-devel@lists.sugarlabs.org/msg07949.html

comment:24 in reply to: ↑ 22 Changed 7 years ago by erikos

Replying to bernie:

Replying to erikos:

James, as far as I have understood, the idea was as well to go back to the old ordering to not confuse people. Bernie might want to comment here.

I agree with erikos. Preferred ordering for me would be the same of 0.82, with the label "My Settings" and, perhaps, the Register button showing new schoolserver icon designed by Gary C. Martin.

We already moved one step ahead i think :)

http://bugs.sugarlabs.org/ticket/1206#comment:19

comment:25 follow-up: Changed 7 years ago by erikos

So, to conclude I think everything that is left is making the 'restart' optional. Quozl's patch does address that. Everyone happy with that?

comment:26 in reply to: ↑ 25 Changed 7 years ago by bernie

  • Cc bernie added

Replying to erikos:

So, to conclude I think everything that is left is making the 'restart' optional. Quozl's patch does address that. Everyone happy with that?

+1! Who's going to post the final patch?

Sorry it took so long to reply, I wasn't on cc.

comment:27 Changed 7 years ago by quozl

0001-revert-earlier-fix-to-1206-and-use-gconf.patch that I proposed eight weeks ago, has had the following comments:

  • tomeu: r+, want to make explicit the risk of confusing users with configurable UI changes, because documentation is going to not always match, (the patch does not do this),
  • virtusanqa (a group?): implement as an optional feature, (the patch does this),
  • dsd: shutdown kept as top option, (the patch does this),
  • erikos: +1,
  • bernie: +1.

Consensus appears to have been reached.

The patch still applies cleanly to HEAD (0.90.2), so it can be considered final. I've rewritten the commit message and posted to mailing list for wider review.

comment:28 Changed 4 years ago by dnarvaez

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:29 Changed 4 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.