Opened 10 years ago

Closed 5 years ago

Last modified 5 years ago

#1181 closed defect (fixed)

Registration should be async

Reported by: rgs Owned by: tomeu
Priority: Normal Milestone: Unspecified
Component: Sugar Version: 0.82.x
Severity: Unspecified Keywords: async registration
Cc: quozl Distribution/OS: OLPC
Bug Status: New

Description

On bad network conditions the Registration process may freeze the whole screen hence this should be made async.

See http://dev.sugarlabs.org/ticket/1152 for a different suggested approach (for fixing this).

Change History (8)

comment:1 Changed 10 years ago by tomeu

  • Milestone changed from 0.86 to 0.88

comment:2 Changed 9 years ago by walter

  • Milestone changed from 0.88 to 0.90

Won't make 0.88. This report came from the field. It may be something we want to prioritize for 0.90.

comment:3 Changed 6 years ago by dnarvaez

  • Milestone changed from 0.90 to Unspecified

comment:4 Changed 6 years ago by dnarvaez

  • Bug Status changed from Unconfirmed to New
  • Priority changed from Unspecified by Maintainer to High
  • Type changed from enhancement to defect

comment:5 Changed 6 years ago by dnarvaez

  • Priority changed from High to Urgent

comment:6 Changed 5 years ago by godiard

  • Priority changed from Urgent to Normal

comment:7 Changed 5 years ago by godiard

  • Cc quozl added
  • Resolution set to fixed
  • Status changed from new to closed

Probably already solved by https://github.com/sugarlabs/sugar/commit/7d3f55e03133e1dc624076dd98ada57698cbaf23

quozl, could you confirm please?

comment:8 Changed 5 years ago by quozl

thanks for drawing my attention to this ticket, i had not yet found it.

my test case was a register attempt on an ad-hoc network, which hangs for a while.

since #1152 and #1181 were raised, i think the duration of the test case hang has reduced because of underlying changes in the stack.

in my opinion, the duration is now short enough that the progress alert is sufficient, and there is less need to make the registration asynchronous.

however, it would be good to hear from the field. there are other network configurations to be tested.

this ticket can be re-opened when that feedback is available.

Note: See TracTickets for help on using tickets.