Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#1147 closed defect (fixed)

Sugar needs to accept None as a layout

Reported by: bemasc Owned by: tomeu
Priority: High Milestone:
Component: Sugar Version: 0.84.x
Severity: Critical Keywords: r+
Cc: sascha_silbe, alsroot Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

See https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/325706, comments 16 and 17.

Sugar should not fail to launch if gconf keys are missing. One-line fix is needed at
http://git.sugarlabs.org/projects/sugar/repos/mainline/blobs/HEAD/src/jarabe/desktop/favoritesview.py#line284

The fix could be as simple as logging a warning and choosing the Ring View if the requested layout is unknown.

This should also cause a bugfix release for 0.84. I have experienced this bug myself in Gentoo.

Attachments (1)

assume_ringlayout.patch (523 bytes) - added by bemasc 11 years ago.
Patch to assume ring layout if the provided layout is unknown

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by sascha_silbe

  • Cc sascha_silbe added

comment:2 follow-up: Changed 11 years ago by tomeu

I have no problem with the suggested change itself, but if packagers aren't properly installing the schema files, important functionality in Sugar will stop working, unless we recode a gconf replacement.

Though we can say that gconf values are user input, and Sugar should indeed be as tolerant as possible there.

About making a bugfix releases, this will depend on the interest that packagers will show.

A patch would be very appreciated, see http://wiki.sugarlabs.org/go/Development_Team/Code_Review

Changed 11 years ago by bemasc

Patch to assume ring layout if the provided layout is unknown

comment:3 in reply to: ↑ 2 ; follow-up: Changed 11 years ago by bemasc

  • Cc alsroot added

Replying to tomeu:

I have no problem with the suggested change itself, but if packagers aren't properly installing the schema files, important functionality in Sugar will stop working, unless we recode a gconf replacement.

Though we can say that gconf values are user input, and Sugar should indeed be as tolerant as possible there.

I agree with this. Sugar should always work, no matter what the user does to $HOME. If the contents of .gconf or .sugar are bizarre and invalid, Sugar should respond intelligently, not just die.

About making a bugfix releases, this will depend on the interest that packagers will show.

I think I can convince alsroot to make a new release for Gentoo, at least, since that is where I experienced this bug.

A patch would be very appreciated, see http://wiki.sugarlabs.org/go/Development_Team/Code_Review

Attached a patch to show what I'm thinking about, though I haven't tested it.

comment:4 in reply to: ↑ 3 Changed 11 years ago by alsroot

Replying to bemasc:

Replying to tomeu:

I have no problem with the suggested change itself, but if packagers aren't properly installing the schema files, important functionality in Sugar will stop working, unless we recode a gconf replacement.

Though we can say that gconf values are user input, and Sugar should indeed be as tolerant as possible there.

I agree with this. Sugar should always work, no matter what the user does to $HOME. If the contents of .gconf or .sugar are bizarre and invalid, Sugar should respond intelligently, not just die.

at first, it was gentoo-overlay bug when gconf schema wasn't installed, now its fixed(and after updating sugar user will get proper gconf values)

About making a bugfix releases, this will depend on the interest that packagers will show.

I think I can convince alsroot to make a new release for Gentoo, at least, since that is where I experienced this bug.

A patch would be very appreciated, see http://wiki.sugarlabs.org/go/Development_Team/Code_Review

Attached a patch to show what I'm thinking about, though I haven't tested it.

comment:5 Changed 11 years ago by tomeu

  • Keywords r? added
  • Milestone changed from Unspecified by Release Team to 0.86
  • Priority changed from Unspecified by Maintainer to High
  • Severity changed from Unspecified to Critical

Setting the r? keyword so it appears in the review queue.

comment:6 Changed 11 years ago by tomeu

  • Keywords r+ added; r? removed
  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 7 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.