Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#1140 closed defect (notabug)

Speak did not work well on SoaS on the GPA computers

Reported by: CarolineM Owned by: alsroot
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar on a Stick (SoaS) Version: Unspecified
Severity: Unspecified Keywords: GPA
Cc: Distribution/OS: Unspecified
Bug Status: Needinfo

Description

Sometimes it talked and sometimes there was no sound. Same computer, sound came and went.

Died fairly frequently.

sr/lib/python2.6/site-packages/sugar/util.py:25: DeprecationWarning: the sha module is deprecated; use the hashlib module instead

import sha

1249491192.520438 WARNING root: No gtk.AccelGroup in the top level window.
1249491192.877089 WARNING root: No gtk.AccelGroup in the top level window.

/usr/lib/python2.6/site-packages/sugar/graphics/window.py:120: GtkWarning: gtk_container_remove: assertion `GTK_IS_TOOLBAR (container)
widget->parent == GTK_WIDGET (container)' failed

self._vbox.remove(self.toolbox)

(sugar-activity:2169): DEBUG: Got client ID "10451b8b19cfe8893f124949119544190200000021030000"
(sugar-activity:2169): DEBUG: Setting initial properties
(sugar-activity:2169): DEBUG: Received SaveYourself(SmSaveLocal, !Shutdown, SmInteractStyleNone, !Fast) in state idle
(sugar-activity:2169): DEBUG: Sending SaveYourselfDone(True) for initial SaveYourself
(sugar-activity:2169): DEBUG: Received SaveComplete message in state save-yourself-done

Change History (5)

comment:1 Changed 10 years ago by gregorio

  • Keywords GPA added

Hi All,

Can anyone look at this and comment or ask for more info.

Speak was very popular with the kids so it would be great to have it working in top form.

e.g. this comment: 'The kids saw the Speak icon and several
said they want to make the "computer talk"'

from:
http://www.mail-archive.com/iaep@lists.sugarlabs.org/msg05534.html

Thanks,

Greg S

comment:2 Changed 9 years ago by alsroot

  • Bug Status changed from Unconfirmed to Needinfo

I got the same result in some one soas releases on my notebook,
it was sporadic sound issues(not only in Speak), removing pulse and using pure alsa worked well in my case.

Could some who have similar issues and experienced in pulse/alsa stuff recheck it bu removing pulse?

comment:3 Changed 9 years ago by alsroot

  • Owner changed from jminor to alsroot
  • Status changed from new to assigned

comment:4 Changed 9 years ago by alsroot

  • Resolution set to notabug
  • Status changed from assigned to closed

It looks like more non Speak issue, so I'm closing it as notabug
feel free to reopen if issue is reproducible only in Speak.

comment:5 Changed 9 years ago by sascha_silbe

  • Component changed from Speak to SoaS
  • Distribution/OS changed from SoaS to Unspecified

Bulk change distribution=SoaS -> component=SoaS

Note: See TracTickets for help on using tickets.