Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#1098 closed defect (fixed)

Fix .xoj support

Reported by: alsroot Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: 0.84.x
Severity: Unspecified Keywords: r+
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

At present sugar fails on uploading .xoj to Journal

Attachments (3)

sugar-1098 (3.7 KB) - added by alsroot 10 years ago.
0001-journalentrybundle.install-use-install_dir-param.patch (1.3 KB) - added by martin.langhoff 10 years ago.
0001-Clean-up-some-.xoj-registry-code-1098.patch (1.3 KB) - added by alsroot 10 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 10 years ago by alsroot

  • Owner changed from tomeu to alsroot
  • Status changed from new to assigned

Changed 10 years ago by alsroot

comment:2 Changed 10 years ago by alsroot

  • Keywords r? added
  • Owner changed from alsroot to tomeu

comment:3 Changed 10 years ago by alsroot

  • Milestone changed from Unspecified by Release Team to 0.84

comment:4 Changed 10 years ago by tomeu

  • Keywords r+ added; r? removed
  • Resolution set to fixed
  • Status changed from assigned to closed

Pushed to both 0.84 and HEAD. Thanks!

comment:5 follow-up: Changed 10 years ago by martin.langhoff

  • Resolution fixed deleted
  • Status changed from closed to reopened

Debugging this problem on 0.84.5 (the fix was in 0.84.6) I wrote a slightly different patch.

Reviewing Erikos' patch, now that I've found this bugreport :-), it is much better and cleaner than mine, except for a minor cleanup (attached).

So I am reopening for this minor cleanup (which is not worth a separate bug really). Hope that's a reasonable flow.

comment:6 in reply to: ↑ 5 Changed 10 years ago by tomeu

Replying to martin.langhoff:

Debugging this problem on 0.84.5 (the fix was in 0.84.6) I wrote a slightly different patch.

Reviewing Erikos' patch, now that I've found this bugreport :-), it is much better and cleaner than mine, except for a minor cleanup (attached).

So I am reopening for this minor cleanup (which is not worth a separate bug really). Hope that's a reasonable flow.

Sorry, not sure what is being requested here, where is Erikos' patch?

comment:7 Changed 10 years ago by erikos

  • Keywords olpc-0.84 added

comment:8 Changed 10 years ago by alsroot

  • Milestone changed from 0.84 to 0.88

We have a mess with bundle types related code for a long time, some proposals poped up several times but the problem was that it happened just before releasing new sugar (like now:).

Last patch is cleaning some code, I guess it shouldn't introduce regressions since we already had special install() declaration for .xoj, so make it more special shouldn't be a problem.

comment:9 Changed 10 years ago by alsroot

  • Resolution set to fixed
  • Status changed from reopened to closed

http://git.sugarlabs.org/projects/sugar/repos/mainline/commits/fb81d3a51f29b0bf71843bb5540e508b6d480c25

so, in martin.langhoff's patch, install()'s argument should not be used at all

comment:10 Changed 10 years ago by sayamindu

  • Keywords olpc-0.84+ added; olpc-0.84 removed

Cherry-picked to 0.84

comment:11 Changed 10 years ago by sayamindu

  • Keywords olpc-0.84+ removed

comment:12 Changed 6 years ago by dnarvaez

  • Milestone 0.88 deleted

Milestone 0.88 deleted

Note: See TracTickets for help on using tickets.