Opened 12 years ago

Closed 8 years ago

#1078 closed defect (incomplete)

Labyrinth activity can't be shared properly

Reported by: luce_quilla Owned by: garycmartin
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: sascha_silbe, tomeu Distribution/OS: Unspecified
Bug Status: Needinfo

Description

The Labyrinth activity can't be shared properly: although it shows and opens for the other person, neither the user nor the changes done by him or her can be seen.

Change History (7)

comment:1 Changed 12 years ago by sascha_silbe

  • Cc sascha_silbe added

comment:2 Changed 12 years ago by garycmartin

  • Bug Status changed from Unconfirmed to Needinfo
  • Component changed from sugar to Labyrinth
  • Owner changed from tomeu to garycmartin
  • Status changed from new to assigned

Thanks for your feedback.

Can you tell me what release of Labyrinth are you using? The current release (v7) is available at http://activities.sugarlabs.org/en-US/sugar/addon/4078 and there is more documentation for the latest release at http://wiki.sugarlabs.org/go/Activities/Labyrinth

Labyrinth does not yet support real-time collaboration, and since its release, it has the "share with" menu disabled. Real-time collaboration is on my todo list, but not sure how soon that will happen.

Regards,
--Gary

comment:3 Changed 12 years ago by luce_quilla

I’m using Labyrinth v7 and I had not noticed that the "share with" menu was disabled. I shared sending an invitation. Thanks.

comment:4 Changed 12 years ago by garycmartin

  • Cc tomeu added

Oooh, interesting thanks. I wonder if I need to do something extra in the Activity to prevent Sugar showing the "Invite to <activity>" buddy menu for activities that have sharing disabled, or if it is a sugar UI bug. Just cc'ing Tomeu incase he has any pointers/hints. I'm pretty sure this buddy menu is appearing for all activities, whatever their sharing abilities.

comment:5 Changed 12 years ago by tomeu

I think that the problem is that the shell doesn't know how many people an activity supports, we may need to add a D-Bus method for this.

comment:6 Changed 9 years ago by godiard

  • Component changed from Labyrinth to sugar

This is a issue with Sugar and not with the activity. Will be addressed with the feature http://wiki.sugarlabs.org/go/Features/Can_share

comment:7 Changed 8 years ago by dnarvaez

  • Resolution set to incomplete
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.