Opened 12 years ago

Closed 9 years ago

Last modified 8 years ago

#1074 closed enhancement (obsolete)

Browse to show right click palette when hovering over images (for testing)

Reported by: garycmartin Owned by: erikos
Priority: Unspecified by Maintainer Milestone:
Component: Browse Version: Git as of bugdate
Severity: Major Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Assigned

Description

Greg Smith mentions in his GPA notes, "[that kids he helped] didn't remember right click on image to download in Browse."

Eduardo H. Silva suggested, "This is one place where palettes aren't opened by hovering. The thinking that Eben told me, was that in websites with many images, lots of palettes appearing would get in the way. I think it should be tested on first hand to see if indeed it would make browsing be a nuisance."

Change History (8)

comment:1 Changed 12 years ago by walter

I agree... we should test this. It was never clear to me why the solution to the lots-of-palettes-appearing problem wasn't just to move the cursor to an area on the screen without an image.

comment:2 Changed 12 years ago by garycmartin

  • Milestone changed from Unspecified by Release Team to 0.86

comment:3 Changed 12 years ago by tomeu

  • Milestone changed from 0.86 to 0.88

Looks like this one won't make 0.88 :(

comment:4 Changed 12 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned
  • Severity changed from Unspecified to Major
  • Version changed from Unspecified to Git as of bugdate

For the technical aspect: Just learned today that I can use the 'addEventListener('mouseover', listener, False)' to the canvas.

comment:5 Changed 10 years ago by RafaelOrtiz

  • Milestone changed from 0.88 to 0.94

Not yet in browse moving to 0.94.

comment:6 follow-up: Changed 9 years ago by manuq

Three years later: is this still wanted?

comment:7 in reply to: ↑ 6 Changed 9 years ago by garycmartin

  • Resolution set to obsolete
  • Status changed from new to closed

Replying to manuq:

Three years later: is this still wanted?

It was only wanted for user testing, to try out the idea to see if it helped or hindered (my feeling is it will be more of a hinderance during normal browsing). Also worth noting that the move towards touch compatibility also changes the scene, as these palettes would be raised by a long touch (touch equivalent), and there is no such interaction (with existing hardware) as hover.

I'll close this as obsolete, though I want to note it would be great to collect Sugar design data through user testing, even just general Sugar UI usage – but it's just such a hard target group to study (age range 6-12, non English speaking, minimal computer use background, privacy issues for gathered video/audio material). Most of the design feedback to date is anecdotal, filtered through deployers, teachers, volunteers, or direct 'itch scratching' from developers.

comment:8 Changed 8 years ago by dnarvaez

  • Milestone 0.94 deleted

Milestone 0.94 deleted

Note: See TracTickets for help on using tickets.