Opened 12 years ago

Closed 8 years ago

Last modified 7 years ago

#1067 closed enhancement (obsolete)

Make a Sugar friendly mozilla theme for Browse

Reported by: garycmartin Owned by: erikos
Priority: High Milestone:
Component: hulahop Version: Unspecified
Severity: Minor Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: New

Description

Perviously, Browse under 0.82 could use some native Sugar theme components (scroll bars). This ability to support the native GTK theme seems to have been lost somewhere in the upgrade/development process.

Attached is a first pass at a custom (non-native) theme that currently provides regular Sugar vertical and horizontal scroll-bars in Browse. Hopefully I'll extend it to cover Sugar style input form widgets et al. for a fully native like look.

Easiest way to test/install seems to be to copy/rename it to /usr/lib/xulrunner-1.9.1/chrome/classic.jar (this overwrites the current default theme) and restart Browse. I'm not sure of the best way to officially include this, suggestions welcome.

Attachments (1)

sugar_v1.jar (309.1 KB) - added by garycmartin 12 years ago.
v1 just includes modifications to make custom vertical and horizontal scroll-bars in the Sugar style

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by garycmartin

v1 just includes modifications to make custom vertical and horizontal scroll-bars in the Sugar style

comment:1 in reply to: ↑ description ; follow-up: Changed 11 years ago by tomeu

Replying to garycmartin:

Easiest way to test/install seems to be to copy/rename it to /usr/lib/xulrunner-1.9.1/chrome/classic.jar (this overwrites the current default theme) and restart Browse. I'm not sure of the best way to officially include this, suggestions welcome.

Yeah, I'm not sure either how it's best to deploy this.

Which files did you need to modify? If only a css file, we may be able to use the XPCOM API to deploy only that instead of the whole skin .jar.

comment:2 in reply to: ↑ 1 Changed 11 years ago by garycmartin

Replying to tomeu:

Yeah, I'm not sure either how it's best to deploy this.

Which files did you need to modify? If only a css file, we may be able to use the XPCOM API to deploy only that instead of the whole skin .jar.

For just the scrollbar, I think it was 1 (maybe 2) .css and a bunch of new image artwork in a global/scrollbar directory. If I get to more of the theme, it will be a whole bunch more files... Not a regular FF user here, but there must be a standard user place to put a new theme .jar file.

comment:3 Changed 11 years ago by tomeu

  • Milestone changed from 0.86 to 0.88
  • Priority changed from Unspecified by Maintainer to High

We should work on this soon after 0.86

comment:4 Changed 11 years ago by FGrose

  • Bug Status changed from Unconfirmed to New
  • Milestone changed from 0.88 to 0.90

comment:5 Changed 8 years ago by manuq

  • Resolution set to obsolete
  • Status changed from new to closed

comment:6 Changed 7 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.