Opened 10 years ago

Closed 6 years ago

#1050 closed enhancement (duplicate)

inform user about exceptions, offer to file a bug report

Reported by: sascha_silbe Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: New

Description

Uncaught exceptions (i.e. those that end up in the logs) are always a sign of a software bug. So at least for the Sugar shell, we should inform the user something bad has happened and how to report it back to us, in order to get it fixed.

Apport seems to do something similar. Haven't used it myself (neither as a developer nor as a user), though . I'm not proposing to use it, BTW, just presenting prior art for comparison.
Gnome Bug Buddy probably is closer to what we want.

Change History (8)

comment:1 Changed 10 years ago by tomeu

  • Milestone changed from 0.86 to 0.88

comment:2 Changed 9 years ago by walter

Something that perhaps we can land in 0.90

comment:3 Changed 9 years ago by sascha_silbe

  • Milestone changed from 0.88 to 0.90

Requires UI changes, no go for 0.88.

comment:4 Changed 6 years ago by dnarvaez

  • Milestone changed from 0.90 to Unspecified

comment:5 Changed 6 years ago by dnarvaez

  • Bug Status changed from New to Unconfirmed

comment:6 Changed 6 years ago by dnarvaez

  • Bug Status changed from Unconfirmed to New

comment:7 Changed 6 years ago by FGrose

See related bug #1366.

comment:8 Changed 6 years ago by dnarvaez

  • Resolution set to duplicate
  • Status changed from new to closed

Yeah marking as a duplicate of that one.

Note: See TracTickets for help on using tickets.