Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#1036 closed defect (notsugar)

metacity FTBFS with -O3 (test suite bug)

Reported by: garycmartin Owned by: tomeu
Priority: Urgent Milestone:
Component: sugar-jhbuild Version: Git as of bugdate
Severity: Major Keywords:
Cc: sascha_silbe Distribution/OS: Unspecified
Bug Status: Assigned

Description

Just trying to build the latest sugar-jhbuild release under F10 and it's failing with the below error. Built cleanly 2 days ago so I assume it's telated to the 0.85.1 release. I've run git pull, sugar-jhbuild update, sugar-jhbuild depscheck, sugar-jhbuild build, then get this error:

Checking for required M4 macros...

libtool.m4 not found
glib-gettext.m4 not found
intltool.m4 not found
pkg.m4 not found

*Error*: some autoconf macros required to build metacity

were not found in your aclocal path, or some forbidden
macros were found. Perhaps you need to adjust your
ACLOCAL_FLAGS?

* Error during phase configure of metacity: ########## Error running ./autogen.sh --prefix /home/garycmartin/sugar-jhbuild/install --libdir '/home/garycmartin/sugar-jhbuild/install/lib' * [17/38]

Change History (15)

comment:1 Changed 11 years ago by sascha_silbe

  • Bug Status changed from Unconfirmed to Assigned
  • Cc sascha_silbe added
  • Milestone changed from Unspecified by Release Team to 0.86
  • Owner changed from sascha_silbe to tomeu
  • Priority changed from Unspecified by Maintainer to Urgent
  • Severity changed from Unspecified to Blocker
  • Status changed from new to assigned
  • Summary changed from sugar-jhbuild failing to build on F10 (metacity autoconf macros error) to metacity FTBFS on all systems

This fails on all buildslaves as well (e.g. build #0 on debian-squeeze-64bit). Reassigning to Tomeu as he has done the change to metacity in sugar-jhbuild.

comment:2 Changed 11 years ago by garycmartin

FWIW, I tried the "-a --clean" build flags just incase, and also removed the complete sugar-jhbuild folder and re-cloned. Still failed at metacity.

comment:3 in reply to: ↑ description ; follow-up: Changed 11 years ago by tomeu

Replying to garycmartin:

Just trying to build the latest sugar-jhbuild release under F10 and it's failing with the below error. Built cleanly 2 days ago so I assume it's telated to the 0.85.1 release. I've run git pull, sugar-jhbuild update, sugar-jhbuild depscheck, sugar-jhbuild build, then get this error:

Checking for required M4 macros...

libtool.m4 not found
glib-gettext.m4 not found
intltool.m4 not found
pkg.m4 not found

Can you check if installing gnome-common fixes that? Thanks!

comment:4 in reply to: ↑ 3 Changed 11 years ago by garycmartin

Replying to tomeu:

Can you check if installing gnome-common fixes that? Thanks!

Thanks Tomeu, no luck I'm afraid. Package gnome-common-2.18.0-1.fc8.noarch already installed and latest version. Nothing to do.

comment:5 Changed 11 years ago by sascha_silbe

After installing the missing dependencies I now get the following error:

gcc -DHAVE_CONFIG_H -I. -I../.. -D_REENTRANT -I/home/sugar/sugar-jhbuild/install/include/gconf/2 -I/home/sugar/sugar-jhbuild/install/include/dbus-1.0 -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/startup-notification-1.0 -O3 -ggdb -Wall -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wcast-align -Wsign-compare -Wall -Werror -ansi -MT test-resizing.o -MD -MP -MF .deps/test-resizing.Tpo -c -o test-resizing.o test-resizing.c
cc1: warnings being treated as errors
test-resizing.c: In function ‘main’:
test-resizing.c:82: error: ‘height’ is used uninitialized in this function
test-resizing.c:94: note: ‘height’ was declared here
make[4]: * [test-resizing.o] Error 1
make[4]: Leaving directory `/home/sugar/sugar-jhbuild/source/metacity/src/wm-tester'

comment:6 Changed 11 years ago by sascha_silbe

metacity is unbuildable on F10 because
a) F10 only has automake 1.9 and 1.11, but not 1.10
b) gnome-autogen.sh (used by metacity autogen.sh) on F10 complains about ">= 1.10" not being available, but actually checks =1.10.

comment:7 Changed 11 years ago by walter

Builds on Jaunty...

comment:8 Changed 11 years ago by sascha_silbe

Strange. Still fails for me (even after force_checkout) on both Ubuntu Intrepid and Jaunty (F11 and Debian squeeze VMs are still busy with other updates, so can't say anything about them).

comment:9 Changed 11 years ago by sascha_silbe

The test-resizing.c error smells like a compiler bug. I'm puzzled why this occurs on both Intrepid and Jaunty here (which have different gcc versions) here and not at all on Walters Jaunty, though.
Walter, do you run in 32bit (i386) or 64bit (amd64) mode?

comment:10 Changed 11 years ago by sascha_silbe

Even more strangely, it fails in all my VMs (=> 4 differenct gcc versions) and builds fine on the buildslaves (Debian squeeze 32/64bit and F11 64bit on bender, Ubuntu904 on boar; F11 32bit on bender and F10 on boar still updating).
Has anyone else got an Athlon64 and is willing to test?

comment:11 Changed 11 years ago by sascha_silbe

Finally figured it out. It's an actual metacity bug that gcc only catches with -O3.

comment:12 Changed 11 years ago by garycmartin

FWIW: I've moved over to a clean install VM of i686 F11 and finally have sugar-jhbuild built working there (with just squeak failing to build, but I skipped that module for another day).

comment:13 Changed 11 years ago by sascha_silbe

  • Severity changed from Blocker to Major
  • Summary changed from metacity FTBFS on all systems to metacity FTBFS with -O3 (test suite bug)

comment:14 Changed 11 years ago by sascha_silbe

  • Resolution set to notsugar
  • Status changed from assigned to closed

Closing as NotSugar since the patch has been posted upstream where it's bit-rotting now. For recent distros we rely on metacity distro packages anyway so it's not our problem anymore.

comment:15 Changed 7 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.