Opened 12 years ago

Closed 8 years ago

Last modified 8 years ago

#103 closed enhancement (fixed)

Enable plugins to be bundled with Browse

Reported by: sayamindu Owned by: erikos
Priority: major Milestone:
Component: Browse Version: Git as of bugdate
Severity: Major Keywords: r!
Cc: tomeu, bernie, sascha_silbe, manuq Distribution/OS: Unspecified
Bug Status: Needinfo

Description

The attached patch enables Browse to ship plugins in the bundle itself. Apart from the patch two directories need to be created in the Browse directory (plugins, plugins/conf)

Attachments (1)

embed_pdf_in_browse.patch (733 bytes) - added by sayamindu 12 years ago.
Patch to implement the feature

Download all attachments as: .zip

Change History (17)

Changed 12 years ago by sayamindu

Patch to implement the feature

comment:1 Changed 12 years ago by sayamindu

This needs to be applied to the sucrose-0.82 branch as well, in order to cater to the OLPC 8.2.1 release.

comment:2 Changed 12 years ago by erikos

  • Keywords r? added

comment:3 Changed 12 years ago by tomeu

  • Cc tomeu added

There is no way to avoid having code inside Browse about an specific plugin?

comment:4 follow-up: Changed 12 years ago by erikos

I think the comment "# Setup some env variables for the embedded PDF viewer" is a bit misleading, as the env variables are for all the plugins. The MOZ_PLUGIN_PATH for the available plugins and the OPERA_DIR for the mozpluggerrc. Is that assessment right?

Actually, the mozplugger.c looks for the config file as well in $MOZILLA_HOME, which I would prefer in terms of naming.

comment:5 Changed 12 years ago by erikos

  • Type changed from defect to enhancement
  • Version set to Git as of bugdate

comment:6 in reply to: ↑ 4 Changed 12 years ago by sayamindu

Replying to erikos:

I think the comment "# Setup some env variables for the embedded PDF viewer" is a bit misleading, as the env variables are for all the plugins. The MOZ_PLUGIN_PATH for the available plugins and the OPERA_DIR for the mozpluggerrc. Is that assessment right?

Actually, the mozplugger.c looks for the config file as well in $MOZILLA_HOME, which I would prefer in terms of naming.

IIRC, setting MOZILLA_HOME broke something else (I don't clearly remember what). That's why I decided to use OPERA_HOME.

comment:7 Changed 12 years ago by tomeu

  • Bug Status set to Needinfo
  • Distribution/OS set to Unspecified
  • Milestone set to 0.86
  • Severity set to Major

Moving it to 0.86 as seems like a feature. Please comment if you disagree.

comment:8 Changed 12 years ago by erikos

  • Keywords r! added; r? removed

We need to handle the comments from the review, if we want this to land.

comment:9 Changed 12 years ago by tomeu

  • Milestone changed from 0.86 to 0.88

Looks like this one won't make 0.86 :(

comment:10 Changed 11 years ago by walter

  • Milestone changed from 0.88 to 0.90

This one seemed to have fallen off the table. Maybe revisit for 0.90 (along with Lucian's Browse enhancements?)

comment:11 Changed 11 years ago by quozl

Usage data received from Solomon Islands deployment team, David Leeming. The ability to open PDF in the browser without further interaction is currently used in lesson plans based on Sugar 0.82.

I've confirmed the symptom on this ticket by testing Sugar 0.82 and Sugar 0.84:

On Sugar 0.82 in OLPC OS 8.2.1 and os802b5, using Browse 102, a PDF is immediately shown in Browse, by a program called the sugar-pdf-viewer, as a plugin run from the bin directory of the activity. In total a single click is needed to download and begin reading.

On Sugar 0.84 in os13 from Steven M. Parrish, using Browse 108, the PDF is not shown in Browse, but downloaded, with show in journal prompt. In total four clicks are needed to download and begin reading.

comment:12 Changed 11 years ago by quozl

  • Cc bernie added

On Sugar 0.84 on OLPC XO-1.5 we are working around this issue by shipping a forked Browse-108 with this fix applied. See dev.laptop.org #9112 for further details, patch, and .xo file.

comment:13 Changed 10 years ago by sascha_silbe

  • Cc sascha_silbe added

comment:14 Changed 9 years ago by manuq

  • Cc manuq added

comment:15 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Browse in sugar 0.98 have a custom pdf viewer integrated solving this issue.

comment:16 Changed 8 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.