Opened 12 years ago

Closed 12 years ago

#1016 closed defect (wontfix)

journal can fail to mount a usb key with UnpicklingError

Reported by: jpritikin Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: journal Version: 0.82.x
Severity: Unspecified Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

Build 802

See attached python traceback from the JournalActivity log.

Attachments (2)

org.laptop.JournalActivity-1.log (3.4 KB) - added by jpritikin 12 years ago.
bad-image.tar.bz (1.5 MB) - added by jpritikin 12 years ago.
here is an example USB key that fails to mount

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by jpritikin

Changed 12 years ago by jpritikin

here is an example USB key that fails to mount

comment:1 Changed 12 years ago by jpritikin

To reproduce the problem, create a fresh USB filesystem (i.e. mkfs.vfat /dev/sdb1). Unpack the image (i.e., tar -jxf bad-image.tar.bz). Insert into XO. Watch the journal log for exceptions.

I would appreciate it if somebody could test this on sugar 0.84 and GIT HEAD.

comment:2 Changed 12 years ago by jpritikin

Is this problem appearing due to the presence of Hindi filenames on a VFAT filesystem? Can I use ext2 on the USB key instead for better results?

comment:3 Changed 12 years ago by tomeu

The DataStore was rewritten in 0.84 to avoid issues like this one, so I'm not sure anyone will be able to give attention to these issues in 0.82.

comment:4 Changed 12 years ago by jpritikin

  • Resolution set to wontfix
  • Status changed from new to closed

That's completely understandable. Thanks for the clue.

I guess I need to explore loading SoaS on our XO laptops.

Note: See TracTickets for help on using tickets.