Opened 12 years ago

Closed 12 years ago

#1014 closed defect (notabug)

Instability in seeing people in Neighborhood view at GPA on Strawberry

Reported by: CarolineM Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: gregsmithpm@…, walter Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

1246454540.782237 WARNING s-p-s.presenceservice: Error fetching activities for handle 15 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.785403 WARNING s-p-s.presenceservice: Error fetching aliases: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.788431 WARNING s-p-s.presenceservice: Error fetching buddy properties for handle 16 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.791460 WARNING s-p-s.presenceservice: Error fetching current activity for handle 16 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.794496 WARNING s-p-s.presenceservice: Error fetching activities for handle 16 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.797543 WARNING s-p-s.presenceservice: Error fetching aliases: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.800568 WARNING s-p-s.presenceservice: Error fetching buddy properties for handle 17 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.803601 WARNING s-p-s.presenceservice: Error fetching current activity for handle 17 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.806627 WARNING s-p-s.presenceservice: Error fetching activities for handle 17 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.809683 WARNING s-p-s.presenceservice: Error fetching aliases: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.812727 WARNING s-p-s.presenceservice: Error fetching buddy properties for handle 18 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.815784 WARNING s-p-s.presenceservice: Error fetching current activity for handle 18 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.818904 WARNING s-p-s.presenceservice: Error fetching activities for handle 18 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.822010 WARNING s-p-s.presenceservice: Error fetching aliases: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.825057 WARNING s-p-s.presenceservice: Error fetching buddy properties for handle 19 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.828125 WARNING s-p-s.presenceservice: Error fetching current activity for handle 19 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.831179 WARNING s-p-s.presenceservice: Error fetching activities for handle 19 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.834252 WARNING s-p-s.presenceservice: Error fetching aliases: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.838622 WARNING s-p-s.presenceservice: Error fetching buddy properties for handle 20 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.841663 WARNING s-p-s.presenceservice: Error fetching current activity for handle 20 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.844717 WARNING s-p-s.presenceservice: Error fetching activities for handle 20 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.847802 WARNING s-p-s.presenceservice: Error fetching aliases: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.850890 WARNING s-p-s.presenceservice: Error fetching buddy properties for handle 21 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.854035 WARNING s-p-s.presenceservice: Error fetching current activity for handle 21 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.857089 WARNING s-p-s.presenceservice: Error fetching activities for handle 21 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.860158 WARNING s-p-s.presenceservice: Error fetching aliases: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.863202 WARNING s-p-s.presenceservice: Error fetching buddy properties for handle 22 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.866262 WARNING s-p-s.presenceservice: Error fetching current activity for handle 22 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454540.869297 WARNING s-p-s.presenceservice: Error fetching activities for handle 22 None: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files
1246454618.139326 ERROR dbus.connection: Exception in handler for D-Bus signal:
Traceback (most recent call last):

File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 214, in maybe_handle_message

self._handler(*args, kwargs)

File "/usr/share/sugar-presence-service/telepathy_plugin.py", line 514, in _new_channel_cb

self._publish_channel_cb(channel)

File "/usr/share/sugar-presence-service/server_plugin.py", line 342, in _publish_channel_cb

self._add_not_subscribed_to_subscribe_channel()

File "/usr/share/sugar-presence-service/server_plugin.py", line 363, in _add_not_subscribed_to_subscribe_channel

not_subscribed, )

File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in call

keywords)

File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking

message, timeout)

DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.24 was not provided by any .service files

Change History (6)

comment:1 Changed 12 years ago by walter

This was SoaS Strawberry (booted with a helper CD). The hw was old HP desktops, EVOs, with a hardwired ethernet. The systems were configured to point to jabber.sugarlabs.org. The network connection itself was working, e.g., browse worked consistently. The machines initially would connect to the ejabberd server, display XOs and activities in the neighborhood view, but after several seconds, the neighborhood would go empty (except for the xo in the center) and the machine would attempt to connect through salut. Only some machines would occasionally appear in Salut. Every once in a while, we'd be reconnected to the server and momentarily see a populated neighborhood view.

I had my laptop connected to the same network running a very up-to-date jhbuild and experienced the same behavior, only the duty cycle seemed to be much faster. I'd get a flash of the jabber server every few minutes.

It was definitely pingponging between gabble and salut as per ps. At no point did my laptop report that the network itself was down.

There was no one around to query re the network configuration for these machines. No idea what was between us and the Internet.

comment:2 Changed 12 years ago by gregorio

  • Cc gregsmithpm@… added

comment:3 Changed 12 years ago by tomeu

  • Cc walter added

I have seen telepathy-gabble 0.7.25 crashing on my jhbuild, but working reliably after updating to 0.7.28. Strawberry has 0.7.26 but may be worth trying a newer release.

One way of checking this is true is having Walter build tp-gabble 0.7.28 on his jhbuild and testing it there:

http://telepathy.freedesktop.org/releases/telepathy-gabble/telepathy-gabble-0.7.28.tar.gz

comment:4 Changed 12 years ago by tomeu

Another possibility maybe simpler is downloading this package from F12 and installing it in soas:

http://kojipkgs.fedoraproject.org/packages/telepathy-gabble/0.7.28/1.fc12/i586/telepathy-gabble-0.7.28-1.fc12.i586.rpm

comment:5 Changed 12 years ago by walter

Back at the Gardner School today, Gabble (0.7.25) on my jhbuild is stable. Also, on those SoaS Strawberry machines that connected to the net, Gabble was also stable. The problem was that many of the machines seemed not to get an IP address. I did a dhclient by hand and got an IP address, but the network icon never showed up in the Frame and nothing ever showed up in the neighborhood view.

I'll try building gabble 0.7.28 in my jhbuild and confirm that it is working as well.

comment:6 Changed 12 years ago by CarolineM

  • Resolution set to notabug
  • Status changed from new to closed

This was an artifact of the cloning process used to create the sticks

Note: See TracTickets for help on using tickets.