Opened 12 years ago

Closed 10 years ago

Last modified 8 years ago

#1003 closed defect (obsolete)

Chat Strawberry - Can't type in chat

Reported by: CarolineM Owned by: alsroot
Priority: Normal Milestone:
Component: Chat Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Needinfo

Description

This seems to be hardware dependent.

http://www.youtube.com/watch?v=g3-a3jhfh3Y

Change History (7)

comment:1 Changed 12 years ago by garycmartin

Can you confirm the machine was connected to the network. If it can't connect, Chat will not let you type. From what I could see of the "Share with:" toolbar widget did look to be set to "My Neighborhood", but it's hard to tell.

comment:2 follow-up: Changed 12 years ago by CarolineM

hmm not I can't confirm that and given that the wireless was incredibly flacky you have probably nailed it.

Is this perhaps a UI bug? Should Chat tell you you aren't connected rather then just not letting you type?

comment:3 in reply to: ↑ 2 ; follow-up: Changed 12 years ago by garycmartin

Replying to CarolineM:

Is this perhaps a UI bug? Should Chat tell you you aren't connected rather then just not letting you type?

Chat does show a "you are connected" dialogue when you start sharing or resume a shared session, but I'm not sure how well or if it deals with negative network responses. Pretty tough problem, perhaps a grey "connecting..." text could be planted in the input field. With my developer hat on, I could end up trying to code an error dialogue after some N number of seconds saying "connection failed". Problem with this is picking a good N for slow network situations.

Related story: The launching pulse animation for starting an Activity is dumb, dumb, dumb. It just plays for about ~20sec and then stops. If the Activity fails to launch the pulse animation doesn't know, and you can sit there for 20 sec watching it before being dumped back somewhere into Sugar and then looking for the crash log (if you know to look). If the Activity starts in 1sec the pulse animation carries on in the background for ~19sec burning CPU cycles, eating memory and making your first impression of the (otherwise fast launching) Activity sluggish. Oh the perils of timed dialogues...

comment:4 in reply to: ↑ 3 Changed 12 years ago by tomeu

  • Bug Status changed from Unconfirmed to Needinfo
  • Component changed from sugar to Chat
  • Milestone changed from Unspecified by Release Team to 0.86
  • Owner changed from tomeu to morgs
  • Priority changed from Unspecified by Maintainer to Normal

Caroline, Gary: can you summarize what is going on here? Please update the title as needed.

comment:5 Changed 12 years ago by tomeu

  • Owner changed from morgs to alsroot
  • Status changed from new to assigned

comment:6 Changed 10 years ago by RafaelOrtiz

  • Resolution set to obsolete
  • Status changed from assigned to closed

Please test with newer versions of SOAS.

comment:7 Changed 8 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.