Opened 13 years ago

Closed 12 years ago

Last modified 8 years ago

#1 closed enhancement (duplicate)

Add support to Browse for distro-customised start page

Reported by: cwhii Owned by: erikos
Priority: minor Milestone: Unspecified
Component: Browse Version: Unspecified
Severity: Blocker Keywords:
Cc: morgan.collett@…, sridhar Distribution/OS: Unspecified
Bug Status: Resolved

Description

What I did:

Installed sugar on Ubuntu. Invoked sugar and the browser.

What it did:

It displayed "about:blank" with a blank page.

What I expected:

I expected "OLPC Library" with a list of libraries to pick from.

Change History (12)

comment:1 follow-up: Changed 13 years ago by tomeu

Someone with ubuntu experience could explain how that distro deals with content?

Perhaps this ticket should be instead about adding some support to Browse for distros to make it point to some preinstalled content?

comment:2 in reply to: ↑ 1 Changed 13 years ago by morgs

  • Cc morgan.collett@… added
  • Component set to fructose
  • Owner set to tomeu
  • Type changed from task to enhancement

Replying to tomeu:

Someone with ubuntu experience could explain how that distro deals with content?

We haven't got around to working with content bundles yet. I've logged an ubuntu bug for this: https://bugs.launchpad.net/ubuntu/+source/sugar-web-activity/+bug/295110

Perhaps this ticket should be instead about adding some support to Browse for distros to make it point to some preinstalled content?

Yes, that would be a good upstream description of the problem.

comment:3 Changed 12 years ago by marcopg

  • Component changed from fructose to Browse
  • Owner changed from tomeu to erikos

comment:4 follow-up: Changed 12 years ago by morgs

  • Summary changed from Ubuntu Sugar OLPC Library missing to Add support to Browse for distro-customised start page

comment:5 in reply to: ↑ 4 ; follow-up: Changed 12 years ago by cwhii

Replying to morgs:

Browse currently attempts to access "OLPC Library" which if not present displays
"about:blank" instead.

The documentation that I have seen shows the "OLPC Library" as the default. This seems like a valid distribution value for the OLPC XO system.

I would like the SugarLabs code base to contain the infrastructure for whatever content library collections a user will add. The default should have a "Sugar Library" with something useful in it. Any distribution if they do not take any action to change this default will have the SugarLabs created default opening library. The distribution can make whatever changes desired. In the case of an XO system it would presumably be the existing "OLPC Library".

I do not know if the Ubuntu default of no library and no infrastructure is because of explicit action by the Ubuntu team or if it just fell through as a blank default.

comment:6 in reply to: ↑ 5 Changed 12 years ago by morgs

Replying to cwhii:

Replying to morgs:

Browse currently attempts to access "OLPC Library" which if not present displays
"about:blank" instead.

The documentation that I have seen shows the "OLPC Library" as the default. This seems like a valid distribution value for the OLPC XO system.

I would like the SugarLabs code base to contain the infrastructure for whatever content library collections a user will add. The default should have a "Sugar Library" with something useful in it. Any distribution if they do not take any action to change this default will have the SugarLabs created default opening library. The distribution can make whatever changes desired. In the case of an XO system it would presumably be the existing "OLPC Library".

I do not know if the Ubuntu default of no library and no infrastructure is because of explicit action by the Ubuntu team or if it just fell through as a blank default.

The Ubuntu team has not yet packaged any library content. Once we include that in a package, it should be readily installable. However I'm not sure whether to include the standard OLPC library content or to customise it for Ubuntu.

comment:7 Changed 12 years ago by dfarning

  • Resolution set to duplicate
  • Status changed from new to closed

I am closing this bug because it is a distribution specific issue, in this case, Ubuntu.
It exists in Ubuntu as https://bugs.launchpad.net/bugs/295110

comment:8 follow-up: Changed 12 years ago by skierpage

  • Bug Status set to Unconfimed
  • Distribution/OS set to Unspecified
  • Severity set to Blocker

Browse's webactivity.py continues to hardcode its home page to _LIBRARY_PATH = '/usr/share/library-common/index.html'

cwhii's lament I expected "OLPC Library" with a list of libraries to pick from is not going to be fixed by distros simply creating a home page for Browse. OLPC's page showing a library of content you've downloaded is generated by the package olpc-library-common, which seems missing from Sugar 0.84. I filed bug #574 for that.

comment:9 in reply to: ↑ 8 Changed 12 years ago by skierpage

Replying to skierpage:

Browse's webactivity.py continues to hardcode its home page to _LIBRARY_PATH = '/usr/share/library-common/index.html'

The fix for bug #645 set the home page to Browse activity directory/data/index.html if /usr/share/library-common/index.html does not exist, and the former is a static sugarlabs HTML page in git.

comment:10 Changed 10 years ago by sridhar

  • Cc sridhar added
  • Milestone set to Unspecified by Release Team
  • Version set to Unspecified

comment:11 follow-up: Changed 8 years ago by Rach4d

  • Bug Status changed from Unconfirmed to Resolved

comment:12 in reply to: ↑ 11 Changed 8 years ago by erikos

Replying to Rach4d:

Can you elaborate why you think this has been fixed now?

Note: See TracTickets for help on using tickets.