Ticket #4123: abiword.spec

File abiword.spec, 30.8 KB (added by godiard, 11 years ago)
Line 
1%define majorversion 2
2%define minorversion 9
3%define microversion 3
4
5Summary: The AbiWord word processor
6Name: abiword
7Version: %{majorversion}.%{minorversion}.%{microversion}
8Release: 1.git20121011%{?dist}.olpc4
9Epoch: 1
10Group: Applications/Editors
11License: GPLv2+
12
13# generated with svn export
14Source0: abiword-20121011.tar.gz
15
16Source1: http://abisource.com/downloads/abiword/%{version}/source/abiword-docs-%{version}.tar.gz
17Source11: abiword.mime
18Source12: abiword.keys
19Source13: abiword.xml
20URL: http://www.abisource.com/
21Requires: libabiword = %{epoch}:%{version}-%{release}
22
23%description
24AbiWord is a cross-platform Open Source word processor. It is full-featured,
25while still remaining lean.
26
27%package -n libabiword
28Summary: Library for developing applications based on AbiWord's core
29Group: System Environment/Libraries
30Requires: pygobject3
31Patch0: abiword-2.6.0-windowshelppaths.patch
32Patch1: abiword-2.8.3-desktop.patch
33Patch2: abiword-2.6.0-boolean.patch
34Patch3: abiword-plugins-2.6.0-boolean.patch
35
36# Make introspection work
37Patch4: introspection-fixes.patch
38Patch5: memory-allocator-confusion.patch
39Patch6: abi-introspection.diff
40
41# OLPC patch to add touch text handles
42Patch99: abiword-text-handles.diff
43Patch100: handles2.diff
44
45BuildRequires: autoconf, libtool
46BuildRequires: desktop-file-utils
47BuildRequires: fribidi-devel, enchant-devel, wv-devel
48BuildRequires: zlib-devel, popt-devel, libpng-devel
49BuildRequires: gtk3-devel, libgsf-devel
50BuildRequires: boost-devel, t1lib-devel
51BuildRequires: dbus-glib-devel >= 0.70
52BuildRequires: readline-devel
53BuildRequires: bzip2-devel
54BuildRequires: poppler-devel >= 0.4.0
55BuildRequires: ots-devel >= 0.4.2
56BuildRequires: libwpd-devel >= 0.9.0
57BuildRequires: libwpg-devel
58BuildRequires: librsvg2-devel
59BuildRequires: libwmf-devel
60BuildRequires: aiksaurus-devel, aiksaurus-gtk-devel
61BuildRequires: link-grammar-devel >= 4.2.2
62BuildRequires: gtkmathview-devel >= 0.7.5, flex, bison
63BuildRequires: loudmouth-devel
64BuildRequires: asio-devel
65BuildRequires: libsoup-devel
66BuildRequires: gobject-introspection-devel, pygobject3
67
68%description -n libabiword
69Library for developing applications based on AbiWord's core.
70
71%package -n libabiword-devel
72Summary: Files for developing with libabiword
73Group: Development/Libraries
74Requires: libabiword = %{epoch}:%{version}-%{release}
75
76%description -n libabiword-devel
77Includes and definitions for developing with libabiword.
78
79%prep
80# setup abiword
81%setup -q -n abiword-20121011
82
83# patch abiword
84%patch1 -p1 -b .desktop
85%patch2 -p1 -b .boolean
86
87# patch abiword plugins
88#%patch3 -p1 -b .boolean
89%patch4 -p1
90%patch5 -p1
91%patch6 -p1
92
93%patch99 -p1
94%patch100 -p1
95
96# setup abiword documentation
97%setup -q -T -b 1 -n abiword-docs-%{version}
98%patch0 -p1 -b .windowshelppaths
99
100%build
101# build libabiword and abiword
102cd $RPM_BUILD_DIR/abiword-20121011
103# we need to update the generated configuration files because of patch104
104./autogen-common.sh
105autoreconf --force --install
106%configure --disable-static --enable-dynamic --enable-plugins --enable-clipart --enable-templates --enable-introspection
107make %{?_smp_mflags} V=1
108
109# build the documentation
110cd $RPM_BUILD_DIR/abiword-docs-%{version}
111ABI_DOC_PROG=$(pwd)/../%{name}-%{version}/src/abiword ./make-html.sh
112
113%install
114
115# install abiword
116cd $RPM_BUILD_DIR/abiword-20121011
117%{__make} install DESTDIR=$RPM_BUILD_ROOT
118
119# install the documentation
120cd $RPM_BUILD_DIR/abiword-docs-%{version}
121mkdir -p $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{majorversion}.%{minorversion}/AbiWord/help
122cp -rp help/* $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{majorversion}.%{minorversion}/AbiWord/help/
123# some of the help dirs have bad perms (#109261)
124find $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{majorversion}.%{minorversion}/AbiWord/help/ -type d -exec chmod -c o+rx {} \;
125
126# finish up
127mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
128#cp $RPM_BUILD_DIR/abiword-%{version}/abiword_48.png $RPM_BUILD_ROOT%{_datadir}/pixmaps/abiword_48.png
129
130cd $RPM_BUILD_DIR/abiword-20121011
131mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
132desktop-file-install --vendor fedora --add-category X-Fedora \
133  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
134  --add-category X-Red-Hat-Extra --remove-category X-Red-Hat-Base \
135  --add-category Applications --add-category Office \
136  ./abiword.desktop
137# remove the original one (which has X-Red-Hat-Base)  (#107023)
138%{__rm} -f $RPM_BUILD_ROOT/%{_datadir}/applications/abiword.desktop
139
140%{__install} -p -m 0644 -D %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/mime-info/abiword.mime
141%{__install} -p -m 0644 -D %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/mime-info/abiword.keys
142%{__install} -p -m 0644 -D %{SOURCE13} $RPM_BUILD_ROOT%{_datadir}/mime/packages/abiword.xml
143
144# nuke .la files
145%{__rm} -f $RPM_BUILD_ROOT/%{_libdir}/libabiword-%{majorversion}.%{minorversion}.la
146%{__rm} -f $RPM_BUILD_ROOT/%{_libdir}/%{name}-%{majorversion}.%{minorversion}/plugins/*.la
147
148%clean
149%{__rm} -rf $RPM_BUILD_ROOT
150
151%post
152update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
153update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
154
155%postun
156update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
157update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
158
159%files
160%defattr(-,root,root)
161%{_bindir}/abiword
162%{_datadir}/applications/*
163%{_datadir}/mime-info/abiword.mime
164%{_datadir}/mime-info/abiword.keys
165%{_datadir}/mime/packages/abiword.xml
166#%{_datadir}/pixmaps/*.png
167%{_datadir}/icons/hicolor/48x48/apps/abiword.png
168# Abiword help
169%{_datadir}/%{name}-%{majorversion}.%{minorversion}/AbiWord
170%{_mandir}/man1/abiword.1.gz
171
172%files -n libabiword
173%doc $RPM_BUILD_DIR/%{name}-20121011/COPYING $RPM_BUILD_DIR/%{name}-20121011/COPYRIGHT.TXT
174%{_libdir}/girepository-1.0/*.typelib
175%{python_sitearch}/gi/*
176%{_libdir}/libabiword-%{majorversion}.%{minorversion}.so
177%{_libdir}/%{name}-%{majorversion}.%{minorversion}
178%{_datadir}/%{name}-%{majorversion}.%{minorversion}
179# Abiword help - included in GUI app
180%exclude %{_datadir}/%{name}-%{majorversion}.%{minorversion}/AbiWord
181
182%files -n libabiword-devel
183%{_datadir}/gir-1.0/*.gir
184%{_includedir}/%{name}-%{majorversion}.%{minorversion}
185%{_libdir}/pkgconfig/%{name}-%{majorversion}.%{minorversion}.pc
186
187%changelog
188* Mon Feb 27 2012 Tom Callaway <spot@fedoraproject.org> - 1:2.8.6-17
189- fix build against modern glib, libpng
190
191* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.8.6-16
192- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
193
194* Tue Dec 06 2011 Adam Jackson <ajax@redhat.com> - 1:2.8.6-15
195- Rebuild for new libpng
196
197* Tue Aug  9 2011 Peter Robinson <pbrobinson@gmail.com> - 1:2.8.6-14
198- rebuild with link-grammar now its back
199
200* Tue Aug  2 2011 Peter Robinson <pbrobinson@gmail.com> - 1:2.8.6-13
201- rebuild for new asio
202- drop obsolete OLPC and ARM includes
203
204* Tue Aug 02 2011 Marc Maurer <uwog@abisource.com> - 1:2.8.6-12
205- Fix a typo in the previous patch
206
207* Tue Aug 02 2011 Marc Maurer <uwog@abisource.com> - 1:2.8.6-11
208- Fix BZ 716005: --no-undefined is a linker flag, not a g++ flag
209
210* Tue Aug 02 2011 Marc Maurer <uwog@abisource.com> - 1:2.8.6-10
211- Mixed up the microversion and the release
212
213* Tue Aug 02 2011 Marc Maurer <uwog@abisource.com> - 1:2.8.6-9
214- Remove link-grammar from the BR and R until it is revived
215
216* Thu May 05 2011 Chris Tyler <chris@tylers.info> - 1:2.8.6-8
217- Excluded asio-devel from ARM builds
218
219* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.8.6-7
220- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
221
222* Thu Dec 30 2010 Peter Robinson <pbrobinson@gmail.com> - 1:2.8.6-6
223- Rebuild for library soname bumps
224
225* Wed Dec  8 2010 Caolán McNamara <caolanm@redhat.com> - 1:2.8.6-5
226- Rebuild for libwpd 0.9
227
228* Wed Dec  8 2010 Peter Robinson <pbrobinson@gmail.com> - 1:2.8.6-4
229- Rebuild for library soname bumps
230
231* Wed Sep 29 2010 jkeating - 1:2.8.6-3
232- Rebuilt for gcc bug 634757
233
234* Wed Sep 22 2010 Peter Robinson <pbrobinson@gmail.com> - 1:2.8.6-2
235- Move abiword gui help from the library to the app. Fixes 578596
236
237* Sat Aug 14 2010 Marc Maurer <uwog@abisource.com> - 1:2.8.6-1
238- New upstream release
239
240* Sat Jun 05 2010 Marc Maurer <uwog@abisource.com> - 1:2.8.5-1
241- New upstream release
242
243* Fri Apr 16 2010 Marc Maurer <uwog@abisource.com> - 1:2.8.4-1
244- New upstream release
245
246* Thu Apr 08 2010 Marc Maurer <uwog@abisource.com> - 1:2.8.3-2
247- Update .desktop patch
248
249* Thu Apr 08 2010 Marc Maurer <uwog@abisource.com> - 1:2.8.3-1
250- New upstream release
251
252* Tue Mar 02 2010 Marc Maurer <uwog@abisource.com> - 1:2.8.2-1
253- New upstream release
254- Package the man page
255
256* Wed Dec 23 2009 Rahul Sundaram <sundaram@fedoraproject.org> -1:2.8.1-4
257- Rebuild again since the wv soname bump was accidental
258- Remove superflous BuildRoot definitions and removals
259
260* Mon Dec 21 2009 Peter Robinson <pbrobinson@gmail.com> - 1:2.8.1-3
261- Rebuild against new libwv
262
263* Sun Nov 01 2009 Marc Maurer <uwog@abisource.com> - 1:2.8.1-2
264- Rebuild
265
266* Sun Nov 01 2009 Marc Maurer <uwog@abisource.com> - 1:2.8.1-1
267- New upstream release
268
269* Tue Sep 01 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.10-2
270- Unconditionally add the dbus-glib-devel BR since the AbiCollab
271  Sugar backend is now always compiled in, even on non-OLPC
272  platforms.
273
274* Sat Aug 29 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.10-1
275- New upstream release
276
277* Mon Aug 24 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.9-2
278- Make abiword depend on libabiword
279
280* Sun Aug 23 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.9-1
281- New upstream version
282
283* Tue Aug 04 2009 Rex Dieter <rdieter@fedoraproject.org> - 1:2.7.8-2
284- drop Req: mathml-fonts (dep moved to gtkmathview)
285
286* Sun Aug 02 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.8-1
287- New upstream version
288
289* Mon Jul 27 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.7-3
290- Rerun autogen.sh after changing the makefiles
291
292* Mon Jul 27 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.7-2
293- Add a patch to work around a templates makefile bug
294
295* Mon Jul 27 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.7-1
296- New upstream release
297- Add --enable-dynamic to configure so plugins link against libabiword.so
298
299* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.7.6-4
300- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
301
302* Sun Jul 05 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.6-3
303- Re-add updated .desktop patch
304
305* Sun Jul 05 2009 Peter Robinson <pbrobinson@gmail.com> - 1:2.7.6-2
306- Remove old patch
307
308* Sun Jul 05 2009 Peter Robinson <pbrobinson@gmail.com> - 1:2.7.6-1
309- New upstream release
310
311* Fri Jun 26 2009 Peter Robinson <pbrobinson@gmail.com> - 1:2.7.5-3
312- Drop old dependencies. Fixes bug 506023
313
314* Sun Jun 21 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.5-2
315- Package unpackaged icon
316
317* Fri Jun 19 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.5-1
318- New upstream release
319
320* Fri Jun 19 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.4-2
321- Add libsoup-devel BR
322- Remove version from asio-devel BR
323- Add libwpg-devel BR
324- Register the .abicollab extension and mimetype
325
326* Thu Jun 11 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.4-1
327- New upstream release
328
329* Mon Mar 09 2009 Marc Maurer <uwog@abisource.com> - 1:2.6.8-2
330- Make g++ 4.4 and rindex friends again
331
332* Mon Mar 09 2009 Marc Maurer <uwog@abisource.com> - 1:2.6.8-1
333- New upstream release
334
335* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.6.6-10
336- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
337
338* Sat Jan 10 2009 Marc Maurer <uwog@abisource.com> - 1:2.6.6-1
339- New upstream release
340
341* Sun Nov 23 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.5-1
342- New upstream release
343
344* Thu Nov 20 2008 Peter Robinson <pbrobinson@gmail.com> - 1:2.6.4-9
345- Remove unused script to drop perl dependency
346
347* Fri Sep 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1:2.6.4-8
348- add t1lib-devel to BuildRequires, fixes FTBFS
349
350* Mon Jul 21 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.4-7
351- Fix libabiword-devel requires
352
353* Mon Jul 21 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.4-6
354- Drop explicit libabiword requires
355
356* Mon Jul 21 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.4-5
357- Fix typo in patch name
358
359* Mon Jul 21 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.4-4
360- Merge with the OLPC-3 branch
361
362* Sun Jul 13 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.4-3
363- We don't include ispell_dictionary_list.xml anymore, so no
364  need to ghost it
365
366* Sun Jul 13 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.4-2
367- Update patches to apply without fuzz
368
369* Sun Jul 13 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.4-1
370- New upstream release
371
372* Thu May 01 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.3-1
373- New upstream release
374
375* Sun Apr 06 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.2-1
376- New upstream release
377
378* Sun Apr 06 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.1-1
379- New upstream release
380
381* Sat Mar 29 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.0-6
382- Don't forget to cvs add nextgen.sh
383
384* Sat Mar 29 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.0-5
385- Include nextgen.sh as abiword-plugins it's a proper autoconf project
386- Fix 439396: abiword includes its own dictionary?
387- Don't build libabiword, it's broken; re-enable it when we release
388  abiword 2.8, which generates a proper library
389- Drop aspell-devel BR
390
391* Sat Mar 29 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.0-4
392- Don't forget to reautogen after changing the plugin build system
393
394* Sat Mar 29 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.0-3
395- Fix 439395: apply patch to remove any runtime dependency on boost
396
397* Fri Mar 28 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.0-2
398- Add BigEndian32.american.hash that was missing from the disted
399  abiword-extras tarball
400
401* Tue Mar 25 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.0-1
402- New upstream release
403- Split off an experimental devel package
404
405* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1:2.4.6-8
406- Autorebuild for GCC 4.3
407
408* Tue Jan 29 2008 Michel Salim <michel.sylvan@gmail.com> - 1:2.4.6-7
409- Update license field
410- Remove build deps on g++ and libstdc++ (in minimum build environment)
411- Remove .cvsignore files from installed doc; fix abw2html.pl permission
412- Add support for goffice-0.6 when building on Fedora 9 and above
413- Fix for F9 glibc lacking TRUE and FALSE
414
415* Tue Sep 04 2007 Lubomir Kundrak <lkundrak@redhat.com> - 1:2.4.6-6.fc7
416- Fix 248103
417
418* Fri Apr 06 2007 Marc Maurer <uwog@abisource.com> - 1:2.4.6-5.fc7
419- Rebuild
420
421* Fri Apr 06 2007 Marc Maurer <uwog@abisource.com> - 1:2.4.6-4.fc7
422- Fix 234765
423
424* Tue Feb 20 2007 Marc Maurer <uwog@abisource.com> - 1:2.4.6-3.fc7
425- Fix 181799
426
427* Fri Feb 02 2007 Marc Maurer <uwog@abisource.com> - 1:2.4.6-2.fc7
428- Rebuild
429
430* Sun Nov 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.6-1.fc7
431- Update to 2.4.6
432
433* Thu Oct 12 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.5-4.fc6
434- Fix bug 207294
435
436* Mon Sep 11 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.5-3.fc6
437- Rebuild for FC6
438
439* Sat Jul 22 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.5-2.fc6
440- Fix http://bugzilla.abisource.com/show_bug.cgi?id=10229
441
442* Sun Jul 09 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.5-1.fc6
443- Update to 2.4.5
444- Fix bug 196690 - abiword fails to build in mock with minimal
445  build environment
446- Drop the document build patch
447
448* Tue Apr 13 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-2.fc6
449- Fix documentation generation
450- Fix charting support
451
452* Tue Apr 11 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-1.fc6
453- New upstream version
454- Remove the macro patch and update the desktop patch
455
456* Wed Mar 29 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-8.fc6
457- Rebuild
458
459* Wed Mar 08 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-7.fc5
460- Disable the collaboration plugin; it is not working in 2.4.x
461
462* Thu Feb 16 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-6.fc5
463- Rebuild for Fedora Extras 5
464
465* Sun Feb 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-5.fc5
466- bug 171926
467
468* Sat Jan 21 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-4.fc5
469- Disable the PDF plugin for now, as poppler doesn't ship the xpdf
470  headers anymore
471
472* Sat Jan 14 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-3.fc5
473- Remove redundant requires - bug 177305
474
475* Thu Jan 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-2.fc5
476- Bump release, forgot to add desktop patch
477
478* Mon Jan 02 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-1.fc5
479- Update to 2.4.2
480- Add BuildRequires readline-devel for the AbiCommand plugin
481- Add BuildRequires bzip2-devel and poppler-devel for plugins
482- Update desktop patch
483- Patch to fix plugin marcros
484
485* Wed Nov 09 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-4.fc5
486- Fix bug 171928
487
488* Sun Oct 23 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-3.fc5
489- Fix bug 161832: "Abiword is not loading certain modules"
490- Add libgsf dependecy, which was needed all along
491- Disable the collaboration plugin, it is not for general use at all
492
493* Tue Oct 11 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-2
494- Use %%{?dist} in the release name
495
496* Sun Oct 9 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-1
497- Update to 2.4.1
498
499* Mon Oct 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.0-1
500- Require mathml-fonts
501- Don't rerun autogen.sh, no need anymore
502- Update gtkmathview dependency to 0.7.5
503- Update to 2.4.0
504
505* Mon Sep 26 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-2
506- Fix gtkmathview BuildRequires
507
508* Thu Sep 22 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-1
509- Update to 2.3.99
510
511* Sat Sep 10 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.6-1
512- Update to 2.3.6
513- Drop the pango patch
514
515* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-3
516- Rebuild
517
518* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-2
519- Enable the abimathview plugin
520
521* Sun Aug 21 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-1
522- Update to 2.3.5
523
524* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-4
525- Update the pango patch to disable more pango code
526
527* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-3
528- Fix the build after applying the pango disabling patch by
529  rerunning autogen.sh
530
531* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-2
532- Disable the experimental pango renderer
533
534* Thu Aug 17 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-1
535- Update to 2.3.4
536- Add link-grammar dependency
537
538* Thu Jul 28 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.9-1
539- Update to 2.2.9
540- Drop the mailmerge patch again
541
542* Sun Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-2
543- Fix build with mailmerge patch
544
545* Sun Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-1
546- Update to 2.2.8
547
548* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1:2.2.7-2
549- rebuild on all arches
550
551* Mon Apr 4 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.7-1
552- Because we love brown paper bag releases
553
554* Sun Apr 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.6-1
555- Drop the gcc4, wvread, virtdestr and pt64 patches
556- Update the desktop patch
557
558* Fri Mar 15 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-3
559- Fix 64bit build
560- Add virtual destructors to classes with virtual functions
561
562* Fri Mar 14 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-2
563- Remove the --disable-magick plugin switch
564- disable GDA support until the plugin is ported to gnomedb 1.2.x
565- Change the download location from SF to http://www.abisource.com/
566- patch libole2
567- fix read as a macro in new glibc
568
569* Fri Mar  2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.5-1
570- bump to latest stable
571- drop integrated dashboard patch again
572- some gcc4 fixes
573
574* Wed Feb 23 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-2
575- rh#149447# dashboard spam revisited
576
577* Tue Feb 22 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-1
578- bump to latest stable version
579- drop integrated nautilus depend patch
580- drop integrated libwpd depend patch
581
582* Fri Feb 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-4
583- upgrade to libwpd-0.8 and incoroprate necessary changeover patches
584
585* Mon Feb 7 2005 Matthias Clasen <mclasen@redhat.com> - 1:2.2.3-3
586- rebuild
587
588* Mon Feb 2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-2
589- remove unneccessary nautilus dependency
590
591* Mon Jan 17 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-1
592- bump to new version
593- drop integrated silenceabidash patch
594
595* Fri Jan 14 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-4
596- RH#145085# annoying cluepacket message on stdout/stderr
597
598* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 1:2.2.2-3
599- Rebuilt for new readline.
600
601* Tue Jan 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-2
602- RH#143368# use enchant as spellchecker
603
604* Mon Dec 13 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-1
605- bump to new version
606
607* Mon Dec 6 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.1-1
608- bump to new version
609- geometry patch upstreamed
610- security patch upstreamed
611- removeoledecod patch upstreamed
612- regenerate desktop patch
613
614* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-2
615- #abi7961# remove tempnam usages
616
617* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-1
618- bump to latest major stable version
619- #rh140321# sanity check geometry
620
621* Tue Nov  9 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.0.14-1
622- bump to latest stable version
623
624* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.12-4
625- rebuild for python 2.4
626
627* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 1:2.0.12-3
628- Change to PreReq instead of Requires(post), up to 0.9
629
630* Thu Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-2
631- Better Requires desktop-file-utils
632
633* Wed Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-1
634- update to new abiword, + change norwegian wordprocessor translation
635
636* Tue Sep 14 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-3
637- #132389# Add more abiword supported mime types to abiword.desktop
638
639* Mon Sep 6 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-2
640- merge abiword.keys into abiword.desktop
641
642* Fri Aug 27 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-1
643- 2.0.11
644
645* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-2
646- use libgnomedb
647
648* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-1
649- 2.0.10
650- use aiksaurus
651
652* Tue Aug 2 2004 Matthias Clasen <mclasen@redhat.com> 1:2.0.9-4
653- rebuilt
654
655* Thu Jul 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-3
656- #126012# some desktop translations
657
658* Wed Jul 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-2
659- #128004# fix irritating windows looking filenames for generated pngs
660
661* Fri Jul 16 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-1
662- 2.0.9, new version with security fix
663
664* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
665- rebuilt
666
667* Thu May 20 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
668- 2.0.7, new version + gcc34 fixes
669
670* Wed Apr 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
671- 2.0.6, 64bit changes made upstream
672
673* Sat Mar 13 2004 Jeremy Katz <> 1:2.0.5-1
674- 2.0.5
675
676* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
677- rebuilt
678
679* Thu Feb 19 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-3
680- rebuild for newer libots and libwpd
681- fix verify as non-root (#109261)
682- add wpd files to abiword.keys (#114907)
683
684* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
685- rebuilt
686
687* Thu Jan 29 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-1
688- 2.0.3 (fixes build against gtk+ 2.3 and lets us rebuild to fix libcroco dep)
689
690* Wed Dec 17 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.2-2
691- rebuild for new libwpd
692
693* Sun Nov 30 2003 Jeremy Katz <katzj@redhat.com>
694- and librsvg2-devel (#111222)
695
696* Fri Nov 28 2003 Jeremy Katz <katzj@redhat.com>
697- buildrequire libgnomeui-devel (#111164)
698
699* Tue Oct 28 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.1-1
700- 2.0.1
701- really remove duplicate desktop file
702
703* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-6
704- make the docs with the just built abiword so that we don't have to
705  have abiword installed to build the docs (#107279)
706
707* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-5
708- fix linkage to glib 1.2 in hancom plugin (#106033)
709
710* Sun Oct 19 2003 Florian La Roche <Florian.LaRoche@redhat.de>
711- add %%clean specfile target
712
713* Tue Oct 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-4
714- remove duplicate desktop file (#107023)
715
716* Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-3
717- include the help
718- show the clipart (#104577)
719
720* Mon Sep 15 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-2
721- rebuild with newer libwpd and libots to get those plugins
722
723* Sun Sep 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-1
724- 2.0.0
725
726* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.6-1
727- 1.99.6
728
729* Mon Aug 25 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.5-1
730- 1.99.5
731
732* Tue Aug  5 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.3-1
733- 1.99.3
734- put icon in the right place (#101646)
735- fix some 64bit casting issues
736- disable ots plugin for now, doesn't seem to build with ots 0.4.0 :/
737- disable -pedantic -ansi so that it will build
738
739* Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-2
740- ugly hack to deal with libtool silliness on x86_64
741
742* Fri Jul 11 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-1
743- 1.99.2
744- add buildrequires to make sure the ots and wp plugins get built
745- no longer needs libgal2, remove buildrequires
746
747* Mon Jun 16 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.1-1
748- 1.99.1
749
750* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
751- rebuilt
752
753* Mon May 26 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-3
754- rebuild for new libgal2
755
756* Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-2
757- tweak plugins build
758
759* Mon May 12 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-0.2
760- 1.9.1
761- drop old patches, switch to using autoconf based build system instead
762  of diving makefiles
763- build with gnome support
764- build with plugins
765- add patch to build on AMD64
766
767* Mon Apr 28 2003 Tim Powers <timp@redhat.com> 1:1.0.5-2
768- rebuild to fix broken libpspell dep
769
770* Mon Mar 24 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.5-1
771- 1.0.5
772
773* Mon Feb 10 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-2
774- fix for abiword starting off the screen (#82425)
775
776* Thu Jan 23 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-1
777- 1.0.4
778
779* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
780- rebuilt
781
782* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-2
783- make it build on x86_64
784
785* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-1
786- 1.0.3 (#80560)
787- set umask before running mkfontdir in %%post
788- patch AbiWord script to convert utf8 locales into non-utf8 variants (#72633)
789
790* Mon Dec 02 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-7
791- Fix doc lines
792- Fix multilib
793
794* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-6
795- rebuilt with gcc-3.2 (we hope)
796
797* Sat Aug 10 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-5
798- fix help index symlink (#71219)
799
800* Thu Aug  1 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-4
801- add abiword binary symlink for upstream compatibility (#70267)
802
803* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 1.0.2-3
804- rebuild using gcc-3.2-0.1
805
806* Thu Jul 18 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-2
807- use included desktop file (#64447)
808- use desktop-file-install
809
810* Wed Jun 26 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-1
811- 1.0.2
812- disable perl module build since we weren't including it anyway
813
814* Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.0.1-1
815- 1.0.1
816
817* Sun Apr 14 2002 Jeremy Katz <katzj@redhat.com> 0.99.5-1
818- zh_CN and zh_TW fonts.dir were flipped
819- update to 0.99.5 as it fixes some major bugs
820- define ABI_BUILD_VERSION so the about screen gives us a version
821
822* Mon Apr  8 2002 Bennhard Rosenkraenzer <bero@redhat.com> 0.99.4-2
823- 1st try at fixing up CJK (#61590)
824- #if 0'ify font warning dialog (#62909, #64556)
825
826* Tue Apr  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.4-1
827- Update to 0.99.4, fixes #61153
828- Fix #61344
829- Nuke the warning about being unable to add anything to font path,
830  that's not how xfs works.
831
832* Thu Feb 28 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.2-1
833- 0.99.2
834- remove blank lines in fonts.dir
835
836* Thu Jan 31 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.1-1
837- 0.99.1
838
839* Wed Jan 30 2002 Alex Larsson <alexl@redhat.com> 0.9.5-3
840- Added patch to use libpng10
841- Added patch to fix perl build problems.
842
843* Fri Nov 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.5-1
844- 0.9.5
845
846* Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.4.1-1
847- Update to 0.9.4.1 (RFE #54806)
848- Add URL (RFE #54590)
849
850* Thu Jul 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-7
851- Fix uninstall (#49350)
852
853* Sat Jul  7 2001 Tim Powers <timp@redhat.com>
854- rebuilt so that dirs aren't sgid root
855
856* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-5
857- Add build requirements (#45157)
858
859* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-4
860- Remove CVS admin files from documentation (#44916)
861
862* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
863- add s390x patch from <oliver.paukstadt@millenux.com>
864
865* Sat Jun 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
866- add s390 patch from Helge Deller
867
868* Tue May 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-1
869- Update to 0.7.14
870
871* Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
872- Handle MIME type stuff (Bug #27530)
873- Add BuildPrereqs for some of the less common stuff AbiWord uses
874  (gal-devel, gnome-print-devel, libunicode-devel)
875
876* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
877- 0.7.13
878
879* Mon Jan 15 2001 Than Ngo <than@redhat.com>
880- fixed broken code for building
881
882* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
883- 0.7.12
884- copy fonts.dir to fonts.scale so mkfontdir doesn't blow it away
885
886* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
887- Rebuild to get rid of 0777 dirs
888
889* Fri Nov 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
890- 0.7.11
891
892* Sun Aug 20 2000 Preston Brown <pbrown@redhat.com>
893- fix path to chkfontpath, it was wrong.
894
895* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
896- Up Epoch and release
897
898* Mon Aug  7 2000 Jakub Jelinek <jakub@redhat.com>
899- Don't ship AbiWord_s if we have AbiWord_d
900- Register AbiWord's fontpath with xfs
901
902* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
903- Rebuild with new libpng. This fixes Bug #13707 - gotta love it when they
904  change the ABI without increasing the soname!
905- fix tooltip (Bug #14711)
906- move binaries from /usr/share to /usr/lib
907
908* Wed Jul 12 2000 Jakub Jelinek <jakub@redhat.com>
909- Fix build on ia64.
910
911* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
912- automatic rebuild
913
914* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
915- Rebuild with new gcc.
916
917* Sat Jun 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
918- Fix build on ia64
919
920* Fri Jun 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
921- 0.7.10
922- update download location
923
924* Fri Jun  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
925- initial build for main CD
926- clean up specfile
927- fix build with gcc 2.96 and glibc 2.2
928- exclude ia64 for now
929
930* Wed May  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
931- 0.7.9
932
933* Wed Feb  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
934- 0.7.8
935- move the desktop file to /etc/X11/applnk so it can be used in both
936  GNOME and KDE
937- fix up handling of RPM_OPT_FLAGS
938
939* Thu Jan 20 2000 Tim Powers <timp@redhat.com>
940- bzipped source to conserve space.
941
942* Sun Jan  9 2000 Matt Wilson <msw@redhat.com>
943- enable GNOME, remove perl hack to do RPM_OPT_FLAGS
944- added libpng requirement.  0.7.7 requires 1.0.5 libpng ABI
945
946* Tue Jan  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
947- 0.7.7
948- handle RPM_OPT_FLAGS
949
950* Mon Nov 15 1999 Tim Powers <timp@redhat.com>
951- first build for inclusion into Powertools.
952- some things in this spec file are from the abisuite-0.7.5-1mdk package