Opened 16 months ago

Closed 15 months ago

Last modified 13 months ago

#4491 closed defect (fixed)

Record: video recording issues on xo-4 os4

Reported by: godiard Owned by: dsd
Priority: High Milestone:
Component: Record Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Trying to record a video on Record activity, the recorded area is smaller than the preview image (like a digital zoom). If select quality high, is recorded only a black box.

In the log we see:

basetransform gstbasetransform.c:1642 gst_base_transform_prepare_output_buffer:<videoscale0> Caps did not change but allocated size does not match expected size (735000 != 614400)


Attachments (2)

0001-create-gst.bin-for-video-playback.patch (3.4 KB) - added by walter 15 months ago.
testhigh.ogg (449.2 KB) - added by dsd 15 months ago.
test case

Download all attachments as: .zip

Change History (9)

comment:1 Changed 15 months ago by walter

I created a gst.bin in which I set a few additional playback parameters (the same ones that I use in Turtle Art) and it seems to fix the problem. See attachment.

comment:2 Changed 15 months ago by dsd

Thanks for looking at this. Unfortuntely that patch introduces a software rescaling of the image, something that should work in hardware. I will investigate the underlying gstreamer error in the next few days.

comment:3 in reply to: ↑ description Changed 15 months ago by dsd

Replying to godiard:

Trying to record a video on Record activity, the recorded area is smaller than the preview image (like a digital zoom).

This only happens on XO-4s with the ov7670 sensor, which is probably not the common configuration. Anyway, fixed in olpc-kernel f0a3916

Changed 15 months ago by dsd

test case

comment:4 Changed 15 months ago by dsd

For the playback issue with the high res videos, the underlying driver problem can be seen with the attached test case: gst-launch playbin uri=testhigh.ogg

This makes XO-4's libgalcore unhappy because the YUV image planes are not aligned to 64-byte boundaries in the resultant XvImages created at playback time.

comment:5 Changed 15 months ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed

Well this is quite a painful situation: http://dev.laptop.org/ticket/12693

For now I have tweaked the resolution to produce 64-byte-aligned image data, which also moves us to a much more standard res (384x288). Fixed in Record-99.

comment:6 Changed 15 months ago by walter

Shall we open a separate ticket for the zooming problem with low-resolution capture?

comment:7 Changed 13 months ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.