Opened 2 years ago

Closed 22 months ago

Last modified 13 months ago

#3939 closed defect (fixed)

Can not share activity (or shared activity is not shown in the neighborhood view)

Reported by: greenfeld Owned by: erikos
Priority: Immediate Milestone:
Component: Sugar Version: 0.97.x
Severity: Major Keywords: olpc-test-passed
Cc: tonyforster Distribution/OS: OLPC
Bug Status: Assigned

Description

Collaboration seems to be completely broken in OLPC 13.1.0 os2/Sugar 0.97. When testing both salute and gabble users do not see each other in the Network view while using the same network.

Even a user sharing their own activity does not show said shared activity in the Network view.

I need to test this enabling debug logging to capture more information as nothing stands immediately stands out as to why.

Attachments (3)

0001-Snowflakelayout-set_flags-is-deprecated-use-the-prop.patch (1.1 KB) - added by erikos 23 months ago.
first patch for snowflakelayout
0001-SnowflakeLayout-fix-remaining-issues.patch (3.1 KB) - added by erikos 23 months ago.
Snowflakelayout, fix remaining issues
testsnowflakelayout.py (1.0 KB) - added by erikos 23 months ago.
test program for snowflakelayout

Download all attachments as: .zip

Change History (15)

comment:1 Changed 2 years ago by tonyforster

  • Cc tonyforster added

Confirmed, testing with OS2 and OS883, OS2 cannot see other XO or shared activity. OS883 can see OS2 and join an activity it shares.

comment:2 Changed 2 years ago by tonyforster

still present in OS3

comment:3 Changed 2 years ago by AlanJAS

Not only share, I cannot connect to an AP (access point).
The shell file says:

Traceback (most recent call last):

File "/usr/lib/python2.7/site-packages/jarabe/model/neighborhood.py", line 392, in active_activity_changed_cb

connection = self._connection[CONNECTION_INTERFACE_BUDDY_INFO]

TypeError: 'NoneType' object has no attribute 'getitem'
Traceback (most recent call last):

File "/usr/lib/python2.7/site-packages/jarabe/model/neighborhood.py", line 392, in active_activity_changed_cb

connection = self._connection[CONNECTION_INTERFACE_BUDDY_INFO]

TypeError: 'NoneType' object has no attribute 'getitem'
1348346163.976001 ERROR root: set_active() failed: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

comment:4 Changed 2 years ago by tonyforster

I am testing OS3 on XO-1.75, OS3 connects to my wifi modem OK, it is visible on another (11.3.0 OS883) XO but OS883 is invisible to it, Turtleart collaboration hosted by OS3 works OK - both turtles are shared wrt location

comment:5 Changed 2 years ago by tonyforster

my modem is not password protected, AlanjaS is

"-connect to AP: I cannot connect, when you click, appears the "star" but no give me the
"password" window (it's a secured wifi)
" see devel@…

comment:6 Changed 23 months ago by erikos

  • Bug Status changed from Unconfirmed to Assigned
  • Version changed from Unspecified to 0.97.x

(in os5)

Ok, there are tracebacks in the shell logs when I share an activity, looks atm more like shell porting bugs.

comment:7 Changed 23 months ago by erikos

  • Summary changed from Collaboration seems to be completely broken to Can not share activity (or shared activity is not shown in the neighborhood view)

Changed 23 months ago by erikos

first patch for snowflakelayout

Changed 23 months ago by erikos

Snowflakelayout, fix remaining issues

Changed 23 months ago by erikos

test program for snowflakelayout

comment:8 Changed 23 months ago by erikos

  • Keywords r? added
  • Priority changed from Unspecified by Maintainer to Immediate

comment:10 Changed 22 months ago by manuq

  • Keywords olpc-test-pending added
  • Resolution set to fixed
  • Status changed from new to closed

Tested in os11, the pending bits where fixed in #4157 and collaboration is working.

comment:11 Changed 20 months ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

Fixed in 13.1.0 os20 (and a few builds before that).

comment:12 Changed 13 months ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.