Opened 2 years ago

Closed 2 years ago

Last modified 16 months ago

#3774 closed defect (fixed)

Missing key accelerators at Sugar ToggleToolButton

Reported by: danielfrancis Owned by: erikos
Priority: Low Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Minor Keywords: acceletator, accessibility
Cc: humitos, godiard Distribution/OS: Unspecified
Bug Status: Resolved

Description (last modified by danielfrancis)

The accelerator property, typical in the Sugar ToolButtons isn't available for the Sugar ToggleToolButtons.

Attachments (1)

Screenshot of _HelloPropsGtk2 Activity_.png (13.0 KB) - added by humitos 2 years ago.
props.accelerator using gtk2 HelloWorld Activity

Download all attachments as: .zip

Change History (9)

comment:1 Changed 2 years ago by danielfrancis

  • Description modified (diff)
  • Keywords acceletator added; aceletator removed
  • Summary changed from Missing key acelerators at Sugar ToggleToolButton to Missing key accelerators at Sugar ToggleToolButton

comment:3 Changed 2 years ago by humitos

  • Cc humitos godiard added

I tested this on sugar-toolkit (gtk2 version) and it's working properly. Screenshot attached

Changed 2 years ago by humitos

props.accelerator using gtk2 HelloWorld Activity

comment:4 Changed 2 years ago by humitos

This is the chunk of code that I used to test this:

from sugar.graphics.toggletoolbutton import ToggleToolButton
toggle_button = ToggleToolButton('format-text-bold')
toggle_button.props.accelerator = '<Ctrl>B'
toggle_button.set_tooltip('Bold')
toolbar_box.toolbar.insert(toggle_button, -1)
toggle_button.show()

comment:5 Changed 2 years ago by erikos

Thanks for the patch Daniel, pushed to the sugar-toolkit-gtk3 master branch:

http://git.sugarlabs.org/sugar-toolkit-gtk3/sugar-toolkit-gtk3/commit/428d648fe3e8dea574e0b9df03337f220eb6d84a

Thanks Manuel for the testcase. How did you guys come across this issue? Is there a specific use case in an activity? I would rather not touch sugar-toolkit-gtk-2 unless there is a very good reason for it.

comment:6 Changed 2 years ago by godiard

The issue is visible in Write activity, ticket #789

comment:7 Changed 2 years ago by danielfrancis

  • Bug Status changed from Unconfirmed to Resolved
  • Resolution set to fixed
  • Status changed from new to closed

Thanks everybody, the changes landed in git, so, closing.
PS: Luck with the Write Activity.

comment:8 Changed 16 months ago by dnarvaez

  • Component changed from sugar-toolkit-gtk3 to Sugar
Note: See TracTickets for help on using tickets.