Opened 4 years ago

Closed 4 years ago

#2633 closed enhancement (fixed)

enhancement of UI for turtle art

Reported by: billkerr Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Minor Keywords:
Cc: forster@… Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

SUGGESTED IMPROVEMENTS
1) variable blocks icon represents a stack but new users are more likely to relate to a box than a stack
a) replace with a box icon and remove box icon from extras
b) put the boxes before stacks in the palette, since new users will use boxes before stacks

2) extra options
replace with, for example, Einstein icon signifying advanced (take out the box if box used for variable blocks icon)

3) tool tips with mouse hover would be an improvement
who is going to know to click on Help, without being told, in order to obtain tips?

4) Put various colour tiles (set color etc.) in the colour palette

5) sensor palette
replace print volume with print loudness (volume has a double meaning)

Change History (1)

comment:1 Changed 4 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

All good suggestions. Implemented in v106
1) Done
2) I used the "gear" icon instead, as most of the blocks in this palette let you build/customize
3) I did fix the problem with line wrap, but I don't yet have a good model for where to put the help. Having it hover is really annoying as it further clutters the workspace. Perhaps at the bottom of the screen?
4) Done
5) Done for English

Note: See TracTickets for help on using tickets.