Ticket #1651 (closed enhancement: fixed)
|Reported by:||sascha_silbe||Owned by:||sascha_silbe|
|Priority:||Unspecified by Maintainer||Milestone:||Unspecified by Release Team|
|Component:||journal||Version:||Git as of bugdate|
jarabe.journal.model._Cache can be simplified a great deal just by changing the way removes are done. This decreases memory usage (as we don't need to keep a dictionary that just duplicates the list) and also fixes a bug I encountered in my version support branch (but couldn't trigger on mainline).
I've kept the class to minimize the code changes, but I cannot see a reason why we'd need it - a simple list should do.